Results 1 to 5 of 5

Thread: atheros 5007 wifi card doesnt work

  1. #1
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    9

    Default atheros 5007 wifi card doesnt work

    Ok so I have a acer aspire and built in wifi is atheros 5007eg and
    It recognizes I have wpa psk TKIP protection but when I put in my password
    it says connection failed i use the wifi manager and then I even try unsecured
    networks and it says connection failed so, but it works on windows no
    problem , is there a fix or patch for that , or do I need like a madwifi patch
    and do I do something in console.

  2. #2
    Member m1cha3l's Avatar
    Join Date
    May 2008
    Posts
    208

    Default

    i have also found the wireless assistant next to useless

    but if you use the command line it should work

    Code:
    bt ~ # ifconfig ath0 up
    
    bt ~ #iwconfig ath0 essid "name of ap here" key "your network key here"
    
    bt ~ #dhcpcd ath0
    hope this helps

  3. #3
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    2

    Default

    I'm having a similar issue with this card as well in backtrack 4, I used the 'airmon-ng' then it showed my card as wlan0, so I inputted 'airmon-ng start wlan0' . I then got a message saying its in monitor mode but there are 'Insufficient Resources' and then said it was mon0. I tryed then going into the airodump using the following command: 'airodump-ng mon0' and got a similar error and something about a flag, is there a command I'm supposed to use before hand or a patch of some kind to get airodump to work with this card? I'm new to this so some detailed instructions would be appreciated, thanks.

  4. #4
    Just burned his ISO
    Join Date
    Mar 2009
    Posts
    20

    Default

    i had this same laptop and ive resolved the problem already
    i need ya guys to post your lspci result here
    mine is here im dualbooting a dv7-1135nr with Atheros AR5007 which shows in my bt4 prefinal as
    Code:
    05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
    now if that came out on you bt4 installation plz follow this guide if you dont have internet use an usb drive or sd card and trespass the deb files or tar.gz from your working partition to the bt4

    Code:
    hxxp://ubuntu-ky.ubuntuforums.org/showthread.php?t=902860
    change to http have fun
    I aint crazy just a lil mistaken

  5. #5
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    2

    Default

    ok but I'm on a live cd and if I reboot it wont make any difference what changes I made correct? so I would have to use a bootable USB flash drive and have backtrack4 installed on it for this fix I'm assuming?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •