Hi, I have bt4 prefinal

I try injection test on my Intel 5100

I set wlan0 on mode monitor then airmon-ng start wlan0 > mon0
I use alfa (rtl8187) for test > mon1

Injection with intel 5100 in mode -2 -3 -4 -6 -5 -7 failed
Code:
aireplay-ng -9 mon0 -i mon1
For information, no action required: Using gettimeofday() instead of /dev/rtc

20:40:00  Trying broadcast probe requests...
20:40:00  Injection is working!
20:40:01  Found 1 AP

20:40:01  Trying directed probe requests...
20:40:01  00:18:39:AA:79:56 - channel: 11 - 'K world'
20:40:02  Ping (min/avg/max): 1.360ms/37.143ms/40.855ms Power: 223.23
20:40:02  30/30: 100%


20:40:02  Trying card-to-card injection...
20:40:03  Attack -0:           OK
20:40:03  Attack -1 (open):    OK
20:40:03  Attack -1 (psk):     OK
20:40:07  Attack -2/-3/-4/-6:  Failed
20:40:11  Attack -5/-7:        Failed
with alfa all right
Code:
aireplay-ng -9 mon1 -i mon0
For information, no action required: Using gettimeofday() instead of /dev/rtc

20:39:42  Trying broadcast probe requests...
20:39:42  Injection is working!
20:39:44  Found 1 AP

20:39:44  Trying directed probe requests...
20:39:44  00:18:39:AA:79:56 - channel: 11 - 'K world'
20:39:46  Ping (min/avg/max): 1.081ms/83.327ms/106.955ms Power: 233.87
20:39:46  30/30: 100%


20:39:46  Trying card-to-card injection...
20:39:46  Attack -0:           OK
20:39:46  Attack -1 (open):    OK
20:39:46  Attack -1 (psk):     OK
20:39:46  Attack -2/-3/-4/-6:  OK
20:39:46  Attack -5/-7:        OK
Where is the problema? I need pacht driver of intel 5100??