Results 1 to 6 of 6

Thread: installing vmware-tools in vmware-fusion running bt4-prefinal

  1. #1
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    4

    Default installing vmware-tools in vmware-fusion running bt4-prefinal

    this tutorial is based off of the offensive-security website.
    for a better understanding watch the video up and running backtrack 4,
    read the blog post about installing vmware-tools and
    read the instructions contained in vmware-tools-patch-backtrack4-7.8.5-2_6_29.tar

    we will assume 2 things.
    you have just finished installing bt4-prefinal on your virtual machine
    and that machine is hosted on VMware-Fusion-2.0.4

    from the command line enter the username and password you chose during the installation.

    grant yourself superuser powers by typing

    sudo su

    and set a root password by typing

    passwd
    followed by your new password twice.

    fix initrd.gz and splash by typing

    fix-splash

    when asked if you want to replace initrd.gz answer yes (y)

    reboot


    login as root then start networking and X11

    dhclient eth0

    startx

    once X has loaded

    start the vmware-tools installation from the vmware menu.
    open a terminal and

    mkdir /mnt/cdrom
    mount /dev/cdrom3 /mnt/cdrom
    cp /mnt/cdrom/VMwareTools-7.9.3-159196.tar.gz /tmp
    umount /mnt/cdrom

    cancel the vmware tools installation from the virtual machine menu

    cd /tmp

    wget xxx.offensive-security.com/tools/vmware-tools-patch-backtrack4-7.8.5-2_6_29.tar

    tar -xf VMwareTools-7.9.3-159196.tar.gz
    tar -xf vmware-tools-patch-backtrack4-7.8.5-2_6_29.tar

    now we have to edit some things by hand

    cp /tmp/vmware-tools-distrib/lib/modules/source/vmsync.tar /tmp/vmsync.tar
    tar -xf vmsync.tar
    cd vmsync-only

    edit the Makefile and change this line

    $(EXTRA_CFLAGS) -Iinclude2/asm/mach-default \
    to read
    $(EXTRA_CFLAGS) -Iinclude2/asm/mach-default -I$(HEADER_DIR)\

    save and quit

    cd ../
    tar -cf vmsync.tar vmsync-only
    cp /tmp/vmsync.tar /tmp/vmware-tools-distrib/lib/modules/source/vmsync.tar

    edit the file vmwaretools-7.8.5-156735.patch
    and remove this hunk

    --- vmdesched-OLD/Makefile 2009-03-26 22:37:37.000000000 -0500
    +++ vmdesched-only/Makefile 2009-04-08 10:19:50.000000000 -0500
    @@ -99,7 +99,7 @@

    vm_check_build = $(shell if $(CC) $(KBUILD_CPPFLAGS) $(KBUILD_CFLAGS) \
    $(CPPFLAGS) $(CFLAGS) $(CFLAGS_KERNEL) \
    - $(EXTRA_CFLAGS) -Iinclude2/asm/mach-default \
    + $(EXTRA_CFLAGS) -Iinclude2/asm/mach-default -I$(HEADER_DIR) \
    -DKBUILD_BASENAME=\"$(DRIVER)\" \
    -Werror -S -o /dev/null -xc $(1) \
    > /dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi)

    save the file, and run
    ./vmwaretools.sh

  2. #2
    Member Vagabond's Avatar
    Join Date
    Feb 2010
    Posts
    50

    Default

    Unfortunatly this doesn´t work with the vmware-tools that come with Fusion 2.0.5..if anyone has a solution for this, please post !!! THNX

  3. #3
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    4

    Default revised instruction set

    here are the revised instructions for 2.0.5
    start vmware-tools install from the vmware menu
    open a terminal and
    mkdir /mnt/cdrom
    mount /dev/cdrom3 /mnt/cdrom
    cp /mnt/cdrom/VMwareTools-7.9.6-173382.tar.gz /tmp
    umount /mnt/cdrom
    cancel the vmware tools installation from the virtual machine menu
    cd /tmp
    gunzip VMwareTools-7.9.6-173382.tar.gz
    tar -xf VMwareTools-7.9.6-173382.tar
    cd vmware-tools-distrib
    ./vmware-install.pl

  4. #4
    Member Vagabond's Avatar
    Join Date
    Feb 2010
    Posts
    50

    Default

    Thanks for the quick help. The Installation went without any problems, but while rebooting i read an ugly: "cannot mount filesystem: protocol error"

    doing "startx" I read

    (EE) Problem parsing the config file
    (EE) Error parsing the config file

    Fatal server error:
    no screens found
    giving up.
    xinit: Connection refused (errno 111):unable to connect to X server
    xiinit: No such process (errno 3): server error.

    Is was working well before the installation...i had to do the "fix-splash" command again, because somehow the VM-Tools installation undid whatever "fix-splash" did.......Ideas ?

  5. #5
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    4

    Default of devils and details

    First the error message:

    Mounting local filesystems...Error: cannot mount filesystem: Protocol error
    FAILED.

    this message is harmless in and of itself. It simply means that you are not sharing files between the virtual machine and the host. if you enable file sharing it goes away and if you disable file sharing it cries because it can't read the filesystem that you are not sharing.

    as for the boot splash...
    I didn't notice it was gone until you pointed it out.

    running fix-splash again failed to break X11 so I'm not quite sure what happened.

    I did this from a clean installation and it worked for me.

    after login:

    sudo su
    passwd
    exit
    logout

    login as root

    startx

    once X has loaded start vmware-tools install from the vmware menu.
    open a terminal

    mkdir /mnt/cdrom
    mount /dev/cdrom3 /mnt/cdrom
    cp /mnt/cdrom/VMwareTools-7.9.6-173382.tar.gz /tmp
    umount /mnt/cdrom

    cancel the vmware tools installation from the virtual machine menu

    cd /tmp
    gunzip VMwareTools-7.9.6-173382.tar.gz
    tar -xf VMwareTools-7.9.6-173382.tar
    cd vmware-tools-distrib
    ./vmware-install.pl
    vmware-user
    fix-splash
    poweroff

    click on settings
    enable sharing
    add a shared folder
    power on the machine
    login as root
    startx

  6. #6
    Member Vagabond's Avatar
    Join Date
    Feb 2010
    Posts
    50

    Default

    Thank You ! Works awesome now..i think i did two things wrong:

    -doing fix-splash BEFORE the installation
    -doing the installation outside X

    Greetz !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •