Results 1 to 2 of 2

Thread: ioctl(SIOCGIFINDEX) failed: No such device

  1. #1
    anarchoi
    Guest

    Default ioctl(SIOCGIFINDEX) failed: No such device

    Ok first off i have a Toshiba Satellite L300D with an Atheros AR700EG.

    My laptop is not on the "supported hardware" list but i have read on google that all Atheros are supported... (could someone please confirm me that my hardware is supported?)

    So i successfully managed to download and get Backtrack3 working on an usb key. I can boot it,

    After aunching the console and typing "airmon-ng start wlan0" , here's what i get :
    wifi0 Atheros madwifi-ng
    ath0 Atheros madwifi-ng VAP (parent: wifi0)
    (there is around 10 wlan around my house, and i don't see any, including the one i want to test with the proprietary's authorisation...)

    then if i type "airodump-ng -w out -c 10 --bssid 00:16:41:C9:E0:3F wlan0" here's what i get :
    Interface wlan0:
    ioctl(SIOCGIFINDEX) failed: No such device
    Any help would be greatly appreciated!

  2. #2
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    19

    Default Atheros AR700EG works out of the box

    Hi anarchoi, actually there are threads that about atheros card just google "-=Xploitz=- VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial""
    but I am not yet allowed to post the link..

    In backtrack3, the interface is not wlan0 but ath0...

    Try:


    bt ~ # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wifi0 no wireless extensions.

    ath0 IEEE 802.11g ESSID:"" Nickname:""
    Mode:Managed Frequency:2.447 GHz Access Point: Not-Associated
    Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=1/1
    Retryff RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff
    Link Quality=0/70 Signal level=-96 dBm Noise level=-96 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    bt ~ # airmon-ng start wifi0


    Interface Chipset Driver

    wifi0 Atheros madwifi-ng
    ath0 Atheros madwifi-ng VAP (parent: wifi0)
    ath1 Atheros madwifi-ng VAP (parent: wifi0) (monitor mode enabled)

    Then you can work with ath1:

    bt ~ # airodump-ng ath1

    Another method you can try:

    bt ~ # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wifi0 no wireless extensions.

    ath0 IEEE 802.11g ESSID:"" Nickname:""
    Mode:Managed Frequency:2.447 GHz Access Point: Not-Associated
    Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=1/1
    Retryff RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff
    Link Quality=0/70 Signal level=-96 dBm Noise level=-96 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    To destroy ath0 completely:

    bt ~ # wlanconfig ath0 destroy
    bt ~ # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wifi0 no wireless extensions.

    To create ath0 in monitor mode:

    bt ~ # wlanconfig ath0 create wlandev wifi0 wlanmode monitor
    ath0

    Then you can work with ath0:

    bt ~ # airodump-ng ath0

    Hope this helps.
    "If it doesn't sleep, doesn't eat, doesn't take **** breaks and plays poker 24 hours a day - it's a bot!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •