Results 1 to 7 of 7

Thread: asus eeepc 4g/701 card reader

  1. #1
    Senior Member
    Join Date
    Feb 2010
    Posts
    146

    Default asus eeepc 4g/701 card reader

    the sd card reader for the asus 4g/701 eeepc is not working properly. i think this might be attributed to the new kernel as it worked well with ubuntu 7.10 and backtrack3 final. however was inoperable in 4beta and now. code coming

    dmesg looks like this
    Buffer I/O error on device sdb, logical block 2023806
    sd 5:0:0:0: timing out command, waited 180s
    sd 5:0:0:0: [sdb] Unhandled sense code
    sd 5:0:0:0: [sdb] Result: hostbyte=0x00 driverbyte=0x08
    sd 5:0:0:0: [sdb] Sense Key : 0x4 [current]
    sd 5:0:0:0: [sdb] ASC=0x11 ASCQ=0x0
    end_request: I/O error, dev sdb, sector 16190448
    Buffer I/O error on device sdb, logical block 2023806
    sd 5:0:0:0: timing out command, waited 180s
    sd 5:0:0:0: [sdb] Unhandled sense code
    sd 5:0:0:0: [sdb] Result: hostbyte=0x00 driverbyte=0x08
    sd 5:0:0:0: [sdb] Sense Key : 0x4 [current]
    sd 5:0:0:0: [sdb] ASC=0x11 ASCQ=0x0
    end_request: I/O error, dev sdb, sector 16190448
    Buffer I/O error on device sdb, logical block 2023806

    fdisk-l doesn't even list device sdb

    and lsusb spits out
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 002: ID 0951:1606 Kingston Technology
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 152e:2507 LG (HLDS)
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    does anyone know how to fix this? cause it's kicking my butt.

    ** problem was not the sd card. seemed to be and old bios that didn't want to cooperate with the new kernel. but thanks comm. for all you help, nice to see we're all reading AND replying!
    open source = open minds, human knowledge belongs to the world

  2. #2
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    That's weird, I have the same laptop and don't have any problems with it. Can you try a different sd card? So far the ones I've used are SanDisk, and Kingston. In both 4Gb and 8Gb capacities.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  3. #3
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    7

    Default

    Im running BT4 from 16Gb SDHC card on Asus 701 4G without any problems. You probably have malfuncting card or something...

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by Barry View Post
    That's weird, I have the same laptop and don't have any problems with it. Can you try a different sd card? So far the ones I've used are SanDisk, and Kingston. In both 4Gb and 8Gb capacities.
    Would agree with this and the other post in regards to the card itself being faulty. I have only had success with SanDisk personally. I have tried with a cheap off name brand and had no luck getting it to work.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  5. #5
    Junior Member
    Join Date
    Sep 2006
    Posts
    45

    Default

    Mine also works from this setup:

    Pendrive full install following the link on on the Offsec site.
    Mounted, used and edited 2 separate Kingston 2Gig SD cards.

    One question, is there a possibility your eee has been modified in the past? I only say this because i know a common hack is to tap into the internal usb hub or cam, just an idea.

    //side note. I didn't know the eee could take SDHC! thanks

  6. #6
    Senior Member lordplagueis's Avatar
    Join Date
    Jan 2010
    Location
    Virginia
    Posts
    106

    Default

    The problem is with bt4 pre final my sandisk cards work but my transcend cards dont but they work with jaunty so I know its pre final
    HP DV7
    8GB DDR3
    Core i7-720QM
    Nvidia GeForce GT 320M

    BT5-64bit x WIN7-64bit DualBoot

  7. #7
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by aliosity View Post

    One question, is there a possibility your eee has been modified in the past? I only say this because i know a common hack is to tap into the internal usb hub or cam, just an idea.
    Mine is hacked with an internal usb shdc card reader. Both readers work for BT4pre.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •