Results 1 to 7 of 7

Thread: ralink rt2860 doesnt work on eeepc 1000H with wpa2-ccmp

Hybrid View

  1. #1
    Junior Member
    Join Date
    Mar 2009
    Posts
    39

    Default ralink rt2860 doesnt work on eeepc 1000H with wpa2-ccmp

    well running the new backtrack 4 pre-final release i kinda had a problem with the wifi it didnt seem to work. well not for wpa2-ccmp. i know backtrack already have the driver already install but no go. i swear i tried everything modprobing to the ifconfig to trying the ralink legacy still no joy.

    so i fixed it...

    what you do is:
    1) download the rt2860sta driver

    http://www.ralinktech.com.tw/data/dr...A_V2.1.2.0.tgz

    2) extract it normally, now cd into the folder "cd 2009_0521_RT2860_Linux_STA_V2.1.2.0"

    3) then cd in to "os/linux" and "nano config.mk"

    4) change the values of these lines (its at the top kinda confusing). so it looks like this:

    HAS_WPA_SUPPLICANT=y

    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

    5) then just cd back out until your in the root directory of the folder "2009_0521_RT2860_Linux_STA_V2.1.2.0" okay before you type "make && make install" you have to change the kernel file "rt2860sta.ko to rt2860sta.bak." Okay so open new terminal and type:

    cd /lib/modules/2.6.29.4/kernel/drivers/staging/rt2860

    mv rt2860sta.ko rt2860sta.bak

    exit

    6) okay now go back to the other terminal now run " make && make install"
    then "modprobe rt2860sta" then "ifconfig ra0 up"

    7) "reboot"
    yes i said reboot for some odd reason wicd didnt reconfigure for ra0. dunno why i did the refresh and a couple of other things but no go. After reboot it should work. Sorry for the long tutorial but i got the wifi working and the spacing my bad i decided to do it that way because it seemed to better on the eyes.

    "P.S. The new kernel update from BackTrack fixes the problem"
    They ran this hack in V.M.O., so I'm isolating the A.P.I., and just booting the host. -Matthew Farrell

  2. #2
    Member imported_onryo's Avatar
    Join Date
    Apr 2009
    Posts
    109

    Default

    But you can't inject can you? Would think you need a patch? I am also using BT4 pre on a eeepc1000h

    onryo
    Let me explain officer, I am not a hacker. I am a security tester of sorts!

  3. #3
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    7

    Default

    Quote Originally Posted by onryo View Post
    But you can't inject can you? Would think you need a patch? I am also using BT4 pre on a eeepc1000h

    onryo
    There isnt support for injection yet unfortunately for ra2860 in BT4, just gotta be patient and hope for the best
    Or buy Atheros chip based WLAN mini-pci card and change it...

  4. #4
    Member imported_onryo's Avatar
    Join Date
    Apr 2009
    Posts
    109

    Default

    Did you see what Muts wrote on Twitter about the rt2860 working on the now eeepc. I just don't quite know what to modprobe. Maybe you can figure it out?

    Twitter / muts: Just added bcm4322 and rt2 ...

    All the best
    onryo
    Let me explain officer, I am not a hacker. I am a security tester of sorts!

  5. #5
    Junior Member
    Join Date
    Mar 2009
    Posts
    39

    Default

    okay but the thing is that the drivers that the team made for some reason didnt work for me. i seriously tried everything...
    They ran this hack in V.M.O., so I'm isolating the A.P.I., and just booting the host. -Matthew Farrell

  6. #6
    Just burned his ISO
    Join Date
    Sep 2009
    Posts
    1

    Default

    I reboot and it worked but when i turn off/on the computer it doesnt work anymore, some help?

  7. #7
    Just burned his ISO Defc0n1's Avatar
    Join Date
    Feb 2009
    Posts
    4

    Default

    Quote Originally Posted by war10ck216 View Post
    "modprobe rt2860sta" then "ifconfig ra0 up"
    Try configuring these commands at the startup. It is only an idea ... It should works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •