Results 1 to 8 of 8

Thread: Disable built in wireless

  1. #1
    Just burned his ISO
    Join Date
    May 2009
    Posts
    5

    Default Disable built in wireless [SOLVED]

    first of all id like to say hi to everyone as this is my first post.

    Secondally i have recently purchaced an "advent web-book"

    i have successfully installed BT4.b,

    however i was wandering if there is a way to uninstall/disable the built in wireless card on my webbook.
    It is of little use and just gets in the way. Even when the "wireless indicator" LED is off, the device is still active.
    it is automatically being assigned to wlan0,

    Thanks

    H

  2. #2
    Senior Member BigMac's Avatar
    Join Date
    Jan 2008
    Posts
    213

    Default

    rmmod bcm43xx

  3. #3

    Default

    Quote Originally Posted by BigMac View Post
    rmmod bcm43xx

    how do u know he has a bcm43xx card :S

    in any case, i would suggest ifconfig wlan0 down
    Until they become conscious they will never rebel, and until after they have rebelled they cannot become conscious...

  4. #4
    Senior Member
    Join Date
    Feb 2009
    Posts
    153

    Default

    couldnt you just disable the device in bios?

  5. #5
    Just burned his ISO
    Join Date
    May 2009
    Posts
    5

    Default

    Quote Originally Posted by SuspectZero View Post

    in any case, i would suggest ifconfig wlan0 down
    that was one of the first things i tried :/
    i'll look in the bios see if theres an option

  6. #6
    Just burned his ISO
    Join Date
    May 2009
    Posts
    5

    Default

    ok after alot of googling and combining info's ive managed to solve this problem

    here's what i did for anyone interested:

    Code:
    less /proc/modules
    i then scanned through the list of modules, googles a couple that sounded like they may be involved, then saw "rt73usb" which i recognised from aircracks website. (strange it says usb when its internal?)

    Code:
    #modprobe -r rt73usb
    #iwconfig
    confirmed it was disabled.

    I then blacklisted the module so it wouldnt startup on boot.

    Code:
    #nano /etc/modprobe.d/blacklist
    blacklist rt73usb
    rebooted and confirmed.

    Hope this can help someone out in the future

  7. #7

    Default

    good job with the self help and thanks for posting the result and the fix. too many times ppl fix their on problems and leave the thread not thinking that others might be asking the questions they asked. again, good job and thanks.
    Until they become conscious they will never rebel, and until after they have rebelled they cannot become conscious...

  8. #8
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default

    Thanks for doing the research yourself and not expecting to be spoonfed on everything.
    Also a big thanks for posting how you resolved it here in detail so it might help someone.
    Tiocfaidh ár lá

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •