Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Intel Wireless Wi-Fi 5100 Card injection

  1. #1
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    1

    Default Intel Wireless Wi-Fi 5100 Card injection

    Hello,
    I have a Dell Studio 1537 notebook with a Intel Wireless Wi-Fi 5100 Card. This card is supported by BT4 but the injection mode isn’t supported. I found a forum witch says: „In order to get injection working on Intel 5100 card download the latest linux-2.6.27-rc7.tar.bz2 kernel and patch the iwlwifi driver with the diffs from the latest kernel iwlwifi driver changes from Stefanik Gábor here”
    link: tinyshell.be/aircrackng/forum/index.php?topic=4217.0

    So my question: How to change the iwlwifi driver in the BT4?
    Thank you for help!

  2. #2
    Junior Member
    Join Date
    Nov 2008
    Posts
    46

    Default

    There is a package in the repository named firmare-iwlwifi. That package and some help from google should be of some help. I don't think you need to compile a kernel on your own to get it working, though.

  3. #3
    Member
    Join Date
    Jan 2010
    Posts
    140

    Default

    Quote Originally Posted by Mirus View Post
    Hello,
    I have a Dell Studio 1537 notebook with a Intel Wireless Wi-Fi 5100 Card. This card is supported by BT4 but the injection mode isn’t supported. I found a forum witch says: „In order to get injection working on Intel 5100 card download the latest linux-2.6.27-rc7.tar.bz2 kernel and patch the iwlwifi driver with the diffs from the latest kernel iwlwifi driver changes from Stefanik Gábor here”
    link: tinyshell.be/aircrackng/forum/index.php?topic=4217.0

    So my question: How to change the iwlwifi driver in the BT4?
    Thank you for help!
    There's no need to download a patch. According to the changelog for kernel 2.6.28 the iwlagn driver supports injection w/out patching for Intel 5100 cards. BT4 uses 2.6.28.1 kernel. They do have a note about 5100 cards you might want to check out near the bottom of the link I provided.

  4. #4
    Member
    Join Date
    Feb 2007
    Posts
    229

    Default

    Note: To inject management frames with encryption, HW crypto support
    must be disabled using the "swcrypto=1" modparam (or "swcrypto50=1"
    for iwl5000). Otherwise most management frames won't be transmitted.
    ok, now where would these switches be? im a bit lost here

  5. #5
    Junior Member
    Join Date
    Nov 2008
    Posts
    46

    Default

    Do you have a file /etc/modprobe.conf (might also be called discover-modprobe.conf)? If so, you could try to put options iwl4965 swcrypto=1 (or whatever fits your laptop) in there.

  6. #6
    Member
    Join Date
    Jan 2010
    Posts
    140

    Default

    According to the aircrack-ng.org website you need to pass pass the arguments to /etc/modprobe.d/options file.
    http://www.aircrack-ng.org/doku.php?id=iwlagn
    For 4965 card is says run
    Code:
    # echo options iwlagn swcrypto=1 >> /etc/modprobe.d/options
    For 5100 card I would assume run
    Code:
    # echo options iwlagn swcrypto50=1 >> /etc/modprobe.d/options
    Then reboot. I can't confirm that this works as I don't have an Intel 4965 card or 5XXX card to test.
    Alternatively, if you just wanted to check to see if it works without making changes to the options file you could load and unload your driver.
    Code:
    # modprobe -r iwlagn
    # modprobe iwlagn swcrypto50=1

  7. #7
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    1

    Default iwl 5100 injection not working

    Alternatively, if you just wanted to check to see if it works without making changes to the options file you could load and unload your driver.
    Code:
    Code:
    # modprobe -r iwlagn
    # modprobe iwlagn swcrypto50=1
    Hi there larryhaja and thank you for your answers.
    I followed your instructions shown above and my iwl5100 still can't inject. I'm using BT4 and everything works great, except injection. I'll be very thankful if you or someone else can help me with this issue.
    Thanks in advance.

  8. #8
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    1

    Angry

    Hello.

    I have the same problem with Intel WiFi 5100 on ASUS M51VR notebook. Everything works great, but injection is not working correctly. I run the injection test with Aireplay and sometimes he says, that "Injection working" to some APs, but when I try to use it in action it is not working. Aireplay returns:

    Sending Authentication Request
    Authentication successful
    Sending Association Request
    Association successful
    and this is repeated countless times, until Aireplay returns error with some advices.

    I tried almost everything to fix this problem. Running wireless card on the same channel as AP, iwconfig rate 1M, swcrypto50=1, but the problem still exists.

    Please help.
    Thanks in advance.

  9. #9
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    7

    Default

    Quote Originally Posted by swordfish_1 View Post
    Hello.

    I have the same problem with Intel WiFi 5100 on ASUS M51VR notebook. Everything works great, but injection is not working correctly. I run the injection test with Aireplay and sometimes he says, that "Injection working" to some APs, but when I try to use it in action it is not working. Aireplay returns:



    and this is repeated countless times, until Aireplay returns error with some advices.

    I tried almost everything to fix this problem. Running wireless card on the same channel as AP, iwconfig rate 1M, swcrypto50=1, but the problem still exists.

    Please help.
    Thanks in advance.
    I have the same problem, any idea ? Injection appears to get lost.
    Also, i tried to associate to the AP with wpa_supplicant but sometimes when said connected it blocks the interface so i can't use the interface with airodump or aireplay.

  10. #10
    Just burned his ISO
    Join Date
    Sep 2008
    Posts
    6

    Default

    Quote Originally Posted by Mirus View Post
    Hello,
    I have a Dell Studio 1537 notebook with a Intel Wireless Wi-Fi 5100 Card. This card is supported by BT4 but the injection mode isn’t supported. I found a forum witch says: „In order to get injection working on Intel 5100 card download the latest linux-2.6.27-rc7.tar.bz2 kernel and patch the iwlwifi driver with the diffs from the latest kernel iwlwifi driver changes from Stefanik Gábor here”


    So my question: How to change the iwlwifi driver in the BT4?
    Thank you for help!
    To change iwlwifi driver i've used backtrack with persistant changes,

    downloaded compat wireless from here

    wireless. kernel. org/ en / users / Download

    extracted them, gone into dir, downloaded patch for better injection

    patches. aircrack-ng. org/ mac80211_2.6.28-rc4-wl_frag+ack_v3.patch

    now, to patch drivers do

    patch -p1 < mac80211_2.6.28-rc4-wl_frag+ack_v3.patch

    now we have to install drivers

    make
    make install
    make unload
    make load

    so now we have drivers working.

    For fakeauth the aircrack-ng method doesn't works with 4965, and I think doesn't also with 5100...Cause a firmware bug, you have to use a auth with wpa_supplicant, to do this open a file and call it wpa_supplicant.conf, in it type

    etwork={
    ssid="essid of network"
    key_mgmt=NONE
    #wep_key0="fakeauth"
    }

    and then use aircrack suite normally..

    PS: sorry for the spaces into urls but i haven't posted 15 mesg...

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •