Page 1 of 2 12 LastLast
Results 1 to 10 of 23

Thread: Little GRUB help

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    47

    Default Little GRUB help

    I just finish triple boot XP+Backtrack 3+Ubuntu 8.10 and now im need to edit GRUB file in backtrack,i dont know what command to issue?
    I try with :
    nano mnt /sda5/boot/grub/menu.lst
    and it aint work,i got blank screen,sda5 is where Ubuntu is installed.How to edit GRUB?

  2. #2
    Junior Member
    Join Date
    Apr 2009
    Posts
    43

    Default

    Well you need to edit the menu.lst file, that's for sure
    Are you sure that the file/directory exists there?

    Maybe you should do sudo find / -iname "menu.lst" | grep "grub"
    This will find the file you need to edit if you aren't sure where it is

  3. #3
    Junior Member otkaz's Avatar
    Join Date
    Jan 2010
    Location
    Houston, TX
    Posts
    38

    Default

    Quote Originally Posted by sevic33 View Post
    I just finish triple boot XP+Backtrack 3+Ubuntu 8.10 and now im need to edit GRUB file in backtrack,i dont know what command to issue?
    I try with :
    nano mnt /sda5/boot/grub/menu.lst
    and it aint work,i got blank screen,sda5 is where Ubuntu is installed.How to edit GRUB?
    in backtrack its nano /mnt/sda5/boot/grub/menu.lst not "nano mnt /sda5/boot/...."
    or in ubuntu do sudo nano /boot/grub/menu.lst

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Backtrack use lilo and not grub. If you want to use grub just add backtrack to your ubuntu grub menu.lst

  5. #5
    Junior Member
    Join Date
    Jan 2010
    Posts
    47

    Default

    Quote Originally Posted by otkaz View Post
    in backtrack its nano /mnt/sda5/boot/grub/menu.lst not "nano mnt /sda5/boot/...."
    or in ubuntu do sudo nano /boot/grub/menu.lst
    I try nano /mnt/sda5/boot/grub/menu.lst and still got black screen

    @ pureh@te:
    first i install XP then backtrack then Ubuntu,so Grub owerright lilo after Ubuntu installation.

    But when i try to enter Ubuntu i got this massage:

    Code:
    Ubuntu is running in low-graphics mode
    
    Your screen,graphic card,and input device settings could not be detected correctly.You will need to configure these yourself
    I press ok and got this massage:

    Code:
    What would you like to do?
    
    *Run Ubuntu in low-graphics mode for just this session
    
    *Reconfigure graphics
    
    *Troubleshoot the error
    If i press *Run Ubuntu in low-graphics mode for just this session i got this massage:
    Code:
    Stand by one minute while the display restarts...
    and i wait and nothing hapen.
    Same if i try if i try Reconfigure graphic

    But when i try to Troubleshoot the errot i got options:

    Code:
    What information would you like to review?
    
    *Review the xserver log file
    
    *Review the startup errors
    
    *Edit configuration file
    
    *Archive configuration and logs
    And whatever i try i cant enter Ubuntu so i cant edit Grub file,so basicly i only can boot Windows with Grub

    So can anyone can help me with this problems?

    P.S.I do this on my laptop

  6. #6
    Junior Member
    Join Date
    Apr 2009
    Posts
    43

    Default

    Boot from a live CD or USB and then mount your hard drive.
    Then you can edit the grub file

  7. #7
    Junior Member
    Join Date
    Jan 2010
    Posts
    47

    Default

    Quote Originally Posted by Wolfbane View Post
    Boot from a live CD or USB and then mount your hard drive.
    Then you can edit the grub file
    I cant,display is freez.

  8. #8
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default

    That your Ubuntu is having issues coming up does not have anything to do with Grub or Lilo. Did you install any graphics driver?
    Tiocfaidh ár lá

  9. #9
    Junior Member
    Join Date
    Jan 2010
    Posts
    47

    Default

    I try to add backtrack to grub
    Code:
    title Backtrack 3
    
    rootnoverify (hd0,2)
    
    kernel /boot/vmlinuz vga=791 root=/dev/sda2 ro
    
    boot
    And aftet i try to run backtrack with
    #startx
    backtrack 3 its crash,this is error:
    Code:
    kded: ERROR : KUniqueApplication: Registering failed!
    kded: ERROR : Communication problem with kded,it probably crashed
    startkde:Shutting down...

  10. #10
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default

    Maybe you missed to copy something?
    Also besides that you get to the command line ok?
    Tiocfaidh ár lá

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •