Results 1 to 9 of 9

Thread: Taskbar clock in KDE

  1. #1
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default Taskbar clock in KDE

    The taskbar clock in KDE is acting bazerk. I have my timezone set to GMT+9. Everytime my PC boots up, the time jumps forward by a few hours!

    Is the problem in all versions of KDE across all distributions, or is it confined to BT4beta?
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by Virchanza View Post
    The taskbar clock in KDE is acting bazerk. I have my timezone set to GMT+9. Everytime my PC boots up, the time jumps forward by a few hours!

    Is the problem in all versions of KDE across all distributions, or is it confined to BT4beta?
    I have had similar problems with time and linux before (just not bt).
    Is this a dual boot with windows?
    If so it might be because windows is set to local time and bt is using UTC.
    Or your bios uses something different than what the OS is set to.
    Check the bios,Then go from there.
    Try setting it manually
    Code:
    hwclock --set --date="YYYY-MM-DD HH:MM:SS TIMEZONE"
    hwclock -s
    You can keep bt from using UTC by editing
    /etc/default/rcS
    finding the line that has UTC=yes and change it to no
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default

    Quote Originally Posted by archangel.amael View Post
    I have had similar problems with time and linux before (just not bt).
    Is this a dual boot with windows?
    Yes it's a dualboot with Windows, except I haven't booted into Windows in weeks and the problem's still happening.


    If so it might be because windows is set to local time and bt is using UTC. Or your bios uses something different than what the OS is set to.
    I went into my BIOS, and it only has the option for setting time and date. It says nothing at all about timezone or UTC. I suppose the best thing to do here would be to set the BIOS to UTC and then let my operating system deal with the timezone.


    Try setting it manually
    Code:
    hwclock --set --date="YYYY-MM-DD HH:MM:SS TIMEZONE"
    hwclock -s
    When I type "hwclock" in BT4beta, I get:
    Code:
    root@bt:~# hwclock
    Cannot access the Hardware Clock via any known method.
    Use the --debug option to see the details of our search for an access method.
    root@bt:~# hwclock --debug
    hwclock from util-linux-ng 2.14
    hwclock: Open of /dev/rtc failed, errno=2: No such file or directory.
    No usable clock interface found.
    Cannot access the Hardware Clock via any known method.
    root@bt:~#
    I don't suppose you know a way of fixing that? I Google'd it and found that Ubuntu users had to do something like add "rtc" to their list of modules.

    You can keep bt from using UTC by editing
    /etc/default/rcS
    finding the line that has UTC=yes and change it to no
    Funnily enough, this was set to No, and so I changed it to Yes because I think it's best for my BIOS to use UTC.

    Thanks for your help!

    I'm after making some changes to my setup, and I have to reboot before I can say for sure if it's fixed, but I'll let you know if I got things working right
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by Virchanza View Post
    Yes it's a dualboot with Windows, except I haven't booted into Windows in weeks and the problem's still happening.
    I went into my BIOS, and it only has the option for setting time and date. It says nothing at all about timezone or UTC. I suppose the best thing to do here would be to set the BIOS to UTC and then let my operating system deal with the timezone.
    Ok so don't worry about the bios.
    Just make sure the bios, bt, and windows part all use the same time format and everything should be ok.
    Funnily enough, this was set to No, and so I changed it to Yes because I think it's best for my BIOS to use UTC.
    Thanks for your help!
    I'm after making some changes to my setup, and I have to reboot before I can say for sure if it's fixed, but I'll let you know if I got things working right
    If the last part works then again everything should be ok.
    The biggest thing to worry about is making sure all three clocks match up.
    Both will try to get the time from the bios, and then look for a time server somewhere. Windows generally changes whatever is in the bios to whatever time it thinks is correct, based on the timezone info, and the timeserver it checks.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  5. #5
    Member
    Join Date
    Jan 2010
    Posts
    140

    Default

    I have the same issue. Nothing seemed to work.

  6. #6
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by larryhaja View Post
    I have the same issue. Nothing seemed to work.
    Windows ****s it up every time. It does the same on our classroom iMacs that are dual boot with Windows.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  7. #7
    Member
    Join Date
    Jan 2010
    Posts
    140

    Default

    Windows has nothing to do with it. I don't even have Windows installed on my notebook. I had this same problem back when I used Dapper a few years ago (also didn't have windows on it). Not sure what I did to right the situation.

  8. #8
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Again one needs to make sure that the BIOS clock the OS clock and the time zone are set to match one another. Also if your systems uses NTP then it's setting need to reflect the setup you want, or else problems can pop up.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  9. #9
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default

    I didn't get an reply to the thread I posted in which I asked people to try out "hwclock" at the commandline.

    Even if I change the time in Backtrack, the changes doesn't stick, and I think it's because /dev/rtc can't be accessed (which might be a bug in BT, I'm not sure).
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •