Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Backtrack 4 slow, not normal slow

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    5

    Exclamation Backtrack 4 slow, not normal slow

    hello guys,

    i've got a problem with backtrack 4.

    when i run startx it gives me an error that the requested proccessor permission is 0 but is set to -1 (something in that direction can read to very good since the error is gone in a second.

    i now tryed:
    live CD
    USB live boot
    VM ware image.

    this is on my laptop btw, on my desktop it all works fine though it doesnt have wireless connection. and i want to take BT with me...

    in the console screen (befor start x) i dont got any problems at all with slowness. though when i do startx it starts getting wierd. it is like there is a procces running in 95% cpu. so everything responds slow. and gui also responds slow.

    i got a 2.1 gz dual core and 3gb of ram, does anyone know a solution to this?? that would be great, since i realy love to use BT for more stuff but it is ennoying/hard to use it now....


    thanks in advance!

  2. #2
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    5

    Default Re: Backtrack 4 slow, not normal slow

    comon no one has a solution to this?? it has been a month and no replys!

    i might add something: can it have something to do with my screen size?? i have a 15.6 inch screen. wich is not a normal size...

    please respond, i really would like to use BT better!!

    -Fjuxed

  3. #3
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    5

    Default Re: Backtrack 4 slow, not normal slow


    looks like we are both having the same issue.
    I am running backtrack 4 final on usb boot.
    i get the same error when i do startx,
    however i do not believe startx is to blame
    if you look closely, the lag is apparent as soon as it boots to commandline
    for example, if you CAT a file, it loads slow at about 1 line per second
    and CPU fans running a marathon

    one thing i did notice we had closely in common was your computer stats
    maybe its a bug in the programming. something about our machines that makes it not work 100%.
    reply with the stats of your PC.

    this is mine
    HP - Pavilion G50-109NR - 15.4" Display, AMD Athlon X2 QL-60 Dual-Core 1.90 GHz, 120GB HDD | Notebook PC
    Video Graphics NVIDIA GeForce 8200M

    if i find a fix to this, i'll keep you guys updated.

  4. #4
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    1

    Default Re: Backtrack 4 slow, not normal slow

    the problem seems to be in AMD processors. you have to set number of processors from 1 to 2, in device setings before you start up backtrack.

  5. #5
    Developer muts's Avatar
    Join Date
    Jan 2006
    Posts
    272

    Default Re: Backtrack 4 slow, not normal slow

    Also check your Artsd process...see if its maxing out.

  6. #6

    Default Re: Backtrack 4 slow, not normal slow

    I think the solve of the Problem is setting up the 2 processors

  7. #7
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Backtrack 4 slow, not normal slow

    Quote Originally Posted by reeth View Post
    I think the solve of the Problem is setting up the 2 processors
    Not in all cases. As stated by muts and in the fixes section the artsd can startup and consume all cpu resources.

  8. #8
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    5

    Default Re: Backtrack 4 slow, not normal slow

    Quote Originally Posted by rugovit View Post
    the problem seems to be in AMD processors. you have to set number of processors from 1 to 2, in device setings before you start up backtrack.
    i tested out the above and backtrack is detecting both processors

    cat /proc/cpuinfo | grep -c processor

    Quote Originally Posted by muts View Post
    Also check your Artsd process...see if its maxing out.
    i tested out the above and i didn't see the artsd process running

    ps aux | grep artsd

    -------------

    i do believe it is related to my AMD processor, i recall a irrelevant incident where i bought a usb dance revolution pad and it would work slow to register inputs on my AMD cpu pc, but worked fine on intel cpu pc's... I DONT KNOW... thanks for the input though! any other ideas fellow backtrackers?

  9. #9
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    5

    Default Re: Backtrack 4 slow, not normal slow

    oh i forgot to include, i also did TOP and didn't see anything eating up my cpu.


  10. #10
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    4

    Default Re: Backtrack 4 slow, not normal slow

    I had similar issues with poor performance after startx, also running on a laptop. After I updated my Nvidia video driver, life became much faster.

    I did the update as follows (credit to clorus at post Installing NVIDIA graphics drivers - Page 2 - Remote Exploit Forums) :
    - make sure you're running the 2.6.30.9 kernel (uname -r)
    - download Nvidia drivers at Drivers - Download NVIDIA Drivers, saving to /usr/src/drivers/nvidia
    - if required, exit KDE (Ctrl-Alt-Backspace)
    - cd /usr/src/drivers/nvidia
    - sh NVIDIA-Linux-x86-190.53-pkg1.run
    - startx

    This worked for me, and I tell you, if it resolves your issue, you will never have been so happy to see a brand name flash before your eyes.

    Note that the "CUDA with BackTrack" HowTo shows another way of installing nvidia drivers. I don't know if that method is better from a system maintenance point of view.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •