Results 1 to 5 of 5

Thread: Two Wifi Cards - Need Help

  1. #1
    Member imported_onryo's Avatar
    Join Date
    Apr 2009
    Posts
    109

    Default Two Wifi Cards - Need Help

    OK Ill bite my pride and ask an ultra n00b qustion. Point blank "How do you get a 1 card into managed mode and the other into monitor mode." Would like to get theis working with BT4. This is what I am doing but all goes to crap.

    Killall (NetworkManager etc etc)

    modprobe rtl8187
    ifconfig wlan0 up
    iwpriv wlan0 get_site_survey
    iwpriv wlan0 set NetworkType=Infra
    iwpriv wlan0 set AuthMode="WPAPSK"
    iwpriv wlan0 set EncrypType="TKIP"
    iwpriv wlan0 set SSID="T0><1c"
    iwpriv wlan0 set WPAPSK="bigassstring"
    dhclient wlan0

    OK fine I now got my wlan0 working. Can surf on wlan0

    Then I try to put my ath0 (AR5001x works fine in BT) into monitor mode and all goes to crap.
    airmon-ng start ath0 sees my wlan0 and starts doing lame stuff like making vaps called mon0, wifi0..blah.

    Alfa awus036h 500mw (rtl8187 or r8187 drivers got em both and blacklist what I am not using at the time) as wlan0
    Dlink chipset AR5001x (madwifi) as ath0

    I have done some custom work with iw reg set SE in local.rc etc. So I have ch 1-13 etc. Can't see why that would be a problem but it is worth noting.

    All the best
    onryo
    Let me explain officer, I am not a hacker. I am a security tester of sorts!

  2. #2
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by onryo View Post
    OK Ill bite my pride and ask an ultra n00b qustion. Point blank "How do you get a 1 card into managed mode and the other into monitor mode." Would like to get theis working with BT4. This is what I am doing but all goes to crap.

    Killall (NetworkManager etc etc)

    modprobe rtl8187
    ifconfig wlan0 up
    iwpriv wlan0 get_site_survey
    iwpriv wlan0 set NetworkType=Infra
    iwpriv wlan0 set AuthMode="WPAPSK"
    iwpriv wlan0 set EncrypType="TKIP"
    iwpriv wlan0 set SSID="T0><1c"
    iwpriv wlan0 set WPAPSK="bigassstring"
    dhclient wlan0

    OK fine I now got my wlan0 working. Can surf on wlan0

    Then I try to put my ath0 (AR5001x works fine in BT) into monitor mode and all goes to crap.
    airmon-ng start ath0 sees my wlan0 and starts doing lame stuff like making vaps called mon0, wifi0..blah.

    Alfa awus036h 500mw (rtl8187 or r8187 drivers got em both and blacklist what I am not using at the time) as wlan0
    Dlink chipset AR5001x (madwifi) as ath0

    I have done some custom work with iw reg set SE in local.rc etc. So I have ch 1-13 etc. Can't see why that would be a problem but it is worth noting.

    All the best
    onryo

    Shouldn't you be doing "airmon-ng start wifi0" and not the vap (ath0)?
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  3. #3
    Member imported_onryo's Avatar
    Join Date
    Apr 2009
    Posts
    109

    Default

    Been a while since I have been using legacy drivers. In this case madwifi. Stick with the mac80211 when I can. OMG you might be right! I think I was treating the madwi like the rtl8187. If it is something as bionicly stupid as:

    Shouldn't you be doing "airmon-ng start wifi0" and not the vap (ath0)?
    I am going to hold my breath and commit suicide

    All the same I might as well ask "Does anybody else do this and if so how do they do it" Most ppl here have an Alfa and a D-Link in their pentesting bag of tricks. It would be a nice "howto". When I get home tomarrow Ill look more into this. Thx Barry

    All the best!
    onryo!
    Let me explain officer, I am not a hacker. I am a security tester of sorts!

  4. #4
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by onryo View Post
    Been a while since I have been using legacy drivers. In this case madwifi. Stick with the mac80211 when I can. OMG you might be right! I think I was treating the madwi like the rtl8187. If it is something as bionicly stupid as:



    I am going to hold my breath and commit suicide

    All the same I might as well ask "Does anybody else do this and if so how do they do it" Most ppl here have an Alfa and a D-Link in their pentesting bag of tricks. It would be a nice "howto". When I get home tomarrow Ill look more into this. Thx Barry

    All the best!
    onryo!
    I've actually not tried, one of my boxes has 4 wifi cards in it. Maybe this weekend I'll play around with it.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  5. #5
    Member imported_onryo's Avatar
    Join Date
    Apr 2009
    Posts
    109

    Default

    Thx Barry,
    Yup the problem was just what you mentioned Got 3 wifi card now running now. Two in monitor mode and one I am surfing on. I mentioned somebody should write a howto. I guess if everybody said that, linux would not exist. Ill get to it soon.

    Killing your self by holding your breath is like suicide without the commitment

    All the best!
    Let me explain officer, I am not a hacker. I am a security tester of sorts!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •