Results 1 to 10 of 12

Thread: Problem loading db_sqlite3, calling db_driver

Hybrid View

  1. #1
    Member kazalku's Avatar
    Join Date
    Feb 2009
    Posts
    416

    Unhappy Problem loading db_sqlite3, calling db_driver

    My issue is similar to this: http://forums.remote-exploit.org/showthread.php?t=22179 and this: http://forums.remote-exploit.org/showthread.php?t=22017
    I'm using BT4b from a usb with persistent change. Following is the error msg I'm getting:
    msf > load db_sqlite3
    [-]
    [-] The functionality previously provided by this plugin has been
    [-] integrated into the core command set. Use the new 'db_driver'
    [-] command to use a database driver other than sqlite3 (which
    [-] is now the default). All of the old commands are the same.
    [-]
    [-] Error while running command load: Deprecated plugin

    Call stack:
    /pentest/exploits/framework3/plugins/db_sqlite3.rb:15:in `initialize'
    /pentest/exploits/framework3/lib/msf/core/plugin.rb:31:in `new'
    /pentest/exploits/framework3/lib/msf/core/plugin.rb:31:in `create'
    /pentest/exploits/framework3/lib/msf/core/plugin_manager.rb:71:in `load'
    /pentest/exploits/framework3/lib/msf/base/simple/framework.rb:33:in `load'
    /pentest/exploits/framework3/lib/msf/ui/console/command_dispatcher/core.rb:517:in `cmd_load'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:234:in `send'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:234:in `run_command'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:196:in `run_single'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:191:in `each'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:191:in `run_single'
    /pentest/exploits/framework3/lib/rex/ui/text/shell.rb:127:in `run'
    ./msfconsole:78
    msf > db_driver
    [-] Unknown command: db_driver.
    msf > db_create new
    [-] Unknown command: db_create.
    msf >
    I don't want to wipe the drive & start from fresh. Any idea will be appreciated. Cheers
    If you can't explain it simply, you don't understand it well enough -- Albert Einstein

  2. #2
    Just burned his ISO
    Join Date
    Aug 2008
    Posts
    5

    Default

    Same here... IDENTICAL ERROR and same USB install with persistent changes .. and the error occured only after a Fast Track update-everything

    Waiting for something, in the meantime I`ll be looking into it myself.
    Thx

  3. #3
    Member kazalku's Avatar
    Join Date
    Feb 2009
    Posts
    416

    Default

    Quote Originally Posted by brezuicab View Post
    .. and the error occured only after a Fast Track update-everything
    I didn't update fast track, it happened to me before that. Are you sure that in your case it was working before the update?
    If you can't explain it simply, you don't understand it well enough -- Albert Einstein

  4. #4
    Junior Member
    Join Date
    Mar 2009
    Posts
    83

    Default

    When i had this problem, it was because i had updated my metasploit. It wasn't because I updated my fast-track. Maybe try and reinstall sqlite3. My problems only went as far as needing to type in db_driver. It is possible you may need to install an updated version of sqlite3 or just reinstall sqlite3. I am not sure. give that a go and we'll go from there I guess.

  5. #5
    Member
    Join Date
    Dec 2007
    Location
    @InterN0T
    Posts
    315

    Default

    Update or reinstall sqlite (2 and 3). (There should still be support for both)

    Grab the newest SVN of Metasploit. If it doesn't work try the STABLE. :-)

    It can also be the sqlite plugin itself that is malfunctioning or outdated.

    [-] The functionality previously provided by this plugin has been

    [-] integrated into the core command set. Use the new 'db_driver'

    [-] command to use a database driver other than sqlite3 (which

    [-] is now the default). All of the old commands are the same.

    [-]

    [-] Error while running command load: Deprecated plugin
    Looks like it's deprecated, have you tried using db_driver?
    [quote][I]I realized, that I had fallen down from the top of the mountain into a deep, terrifying and dark hole, just to find out that another mountain in front of me, much greater than the previous, was the next step in life. I began to wander uphill on the next mountain of life while I knew it would be much harder than the previous mountain. [/I]- MaXe[/quote]

  6. #6
    Junior Member
    Join Date
    Mar 2009
    Posts
    83

    Default

    in the OP's initial post it shows he tried to use db_driver. but it came up with unknown command.

    msf > db_driver
    [-] Unknown command: db_driver.
    msf > db_create new
    [-] Unknown command: db_create.
    msf >


    looks like he/she is just going to have to reinstall sqlite

  7. #7
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    2

    Lightbulb

    I had the same issue, with emphasis on had

    After updating Metasploit, you need to run this to fix your db_driver issues:

    Code:
    sudo gem install rails --include-dependencies
    It'll reinstall ROR with all it's dependencies, which appears to fix the problem.

    I figured it out when I noticed that the console launched from the webgui of Metasploit seemed to load db_driver and execute db_ commands just fine, after a little bit of digging in the webgui folder I traced the issue back to ROR. Reinstalling it seems to do the job.

    Happy 'sploiting!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •