Results 1 to 7 of 7

Thread: TP-LINK TL-WN321G 54Mbps USB Adapter

  1. #1
    Just burned his ISO
    Join Date
    May 2009
    Posts
    1

    Default TP-LINK TL-WN321G 54Mbps USB Adapter

    Seems to working well straight out of the box.

    Injection works
    Monitoring works

    Only thing, the range is kind of shitty, but you can't expect much for a $20 Wifi USB adapter.

  2. #2
    Very good friend of the forum Virchanza's Avatar
    Join Date
    Jan 2010
    Posts
    863

    Default

    It uses the RT73 by the way (I'm using that exact card right now to access the internet).
    Ask questions on the open forums, that way everybody benefits from the solution, and everybody can be corrected when they make mistakes. Don't send me private messages asking questions that should be asked on the open forums, I won't respond. I decline all "Friend Requests".

  3. #3
    Just burned his ISO
    Join Date
    May 2009
    Posts
    4

    Default Need help to update the drivers for backtrack3

    Quote Originally Posted by psiloinc View Post
    Seems to working well straight out of the box.

    Injection works
    Monitoring works

    Only thing, the range is kind of shitty, but you can't expect much for a $20 Wifi USB adapter.
    ----------------------------
    ok here is the problem
    im trying to download the new drivers
    been told from
    [homepages.tu-darmstadt.de/~p_larbig/wlan/]
    and get the rt73-k2wrlz-3.0.2.tar.bz2
    and to install

    ifconfig rausb0 down
    airdriver-ng remove 31
    tar xvjf rt73-k2wrlz-3.0.2.tar.bz2
    cd rt73*/Module
    make
    make install
    modprobe rt73
    ifconfig rausb0 up


    after going into module
    when i use make command it gives me this error
    make: *** /lib/modules/2.6.21.5/build: No such file or directory. Stop.
    rt73.ko failed to build!
    make: *** [module] Error 1

    so i cant complete the rest
    Any thing any step need to b done that is helpfull (booting from cd backtrack3 with tp-link tl-wn321g which is in support list and the steps are there[backtrack.offensive-security.com/index.php/HCL:Wireless#TP-Link_TL-WN321G]]HCL:Wireless - Offensive-security)

  4. #4
    Junior Member
    Join Date
    Apr 2009
    Posts
    43

    Default

    Quote Originally Posted by psiloinc View Post
    Seems to working well straight out of the box.

    Injection works
    Monitoring works

    Only thing, the range is kind of shitty, but you can't expect much for a $20 Wifi USB adapter.
    Don't know why you re-posted this, unless maybe the "Search" button wasn't working the day you posted?
    See HERE

    Quote Originally Posted by newknight View Post
    ----------------------------
    ok here is the problem
    im trying to download the new drivers
    been told from
    [homepages.tu-darmstadt.de/~p_larbig/wlan/]
    and get the rt73-k2wrlz-3.0.2.tar.bz2
    and to install

    ifconfig rausb0 down
    airdriver-ng remove 31
    tar xvjf rt73-k2wrlz-3.0.2.tar.bz2
    cd rt73*/Module
    make
    make install
    modprobe rt73
    ifconfig rausb0 up


    after going into module
    when i use make command it gives me this error
    make: *** /lib/modules/2.6.21.5/build: No such file or directory. Stop.
    rt73.ko failed to build!
    make: *** [module] Error 1

    so i cant complete the rest
    Any thing any step need to b done that is helpfull (booting from cd backtrack3 with tp-link tl-wn321g which is in support list and the steps are there[backtrack.offensive-security.com/index.php/HCL:Wireless#TP-Link_TL-WN321G]]HCL:Wireless - Offensive-security)
    If you're getting stuck with BT3 set-up you could try BT4 (This is afterall, the BT4 Working Hardware section).

    In BT4 you don't need to do anything to get the card working with all features enabled

  5. #5
    Just burned his ISO
    Join Date
    May 2009
    Posts
    4

    Post

    yes i try its working but the problem i find is
    when i stop my card
    and then use mac changer
    and start it again it sound fine
    but
    when i use airodump-ng
    its goes in next phase and start scaning
    but dont show any wep even i try to let it scan for hour
    if i use
    airodump-ng with out doing the other step mean stop down macchnager and start
    its scan rightway
    is there any reason
    and second question is why we use macchanger
    thanks again repling me

  6. #6
    Junior Member
    Join Date
    Apr 2009
    Posts
    43

    Default

    MAC Changer just hides your real MAC Address, to ensure extra anonymity for yourself.
    It is not required to continue on, and is only an extra precaution.

    I have never used mac changer, so I have not run into this problem.

  7. #7
    Just burned his ISO
    Join Date
    Sep 2009
    Posts
    1

    Default

    hello

    I have a TP-LINK TL-WN321G too and i dont understand why, when i plug the usb on the slot i can find all access points but after 5 minutes nothing seems to be working with wireless assistant / airdump..

    SpoonWEP never worked with TL-WN321G.. I use an asus eee pc 1000h. With the installed wifi card spoonWEP works but doesnt have injection and monitoring (but works!). I did install the latest driver(rt73-k2wrlz-3.0.2.tar.bz2) but nothing happens.

    Signal strength is not my problem,i sit next to my router and cannot find arps/IVs.

    Any advice?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •