Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: problems with permissions changing automatically

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    14

    Default problems with permissions changing automatically

    Hi, I installed BT3 to the hard drive and I created a user, but I cannot login to user until I change the permissions of the /tmp folder to 1777. The problem I am having is that everytime I reset the computer, the permissions on /tmp get reset to drwxr_xr_x. Anyone have a solution? Would be greatly appreciated.

  2. #2

    Default

    When you created your user, did you create a home directory for the account?

  3. #3
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    14

    Default

    Quote Originally Posted by cybrsnpr View Post
    When you created your user, did you create a home directory for the account?
    yes.. /home/user

  4. #4

    Default

    what was the exact command you used to create the user account?

  5. #5
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    14

    Default

    Quote Originally Posted by cybrsnpr View Post
    what was the exact command you used to create the user account?
    I used adduser

  6. #6

    Default

    yes, I understand you used adduser, but what options and switches did you use? There could be a problem with how the directory was created, and knowing the exact syntax would aide in troubleshooting.

  7. #7
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    14

    Default

    Quote Originally Posted by cybrsnpr View Post
    yes, I understand you used adduser, but what options and switches did you use? There could be a problem with how the directory was created, and knowing the exact syntax would aide in troubleshooting.
    I just typed adduser and it guided me through the whole process. I did not use useradd.

    What do you think is causing the /tmp directory to reset its permissions. It's either doing it on startup or shutdown.

  8. #8

    Default

    I think you need to double check that the user account's home directory is correctly set in /etc/passwd and that the permissions on the user's home directory are also correctly set.

  9. #9
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    14

    Default

    Quote Originally Posted by cybrsnpr View Post
    I think you need to double check that the user account's home directory is correctly set in /etc/passwd and that the permissions on the user's home directory are also correctly set.
    they match my settings from my Ubuntu partition.

  10. #10

    Default

    It looks like there may be a fix for your problem on THIS blog.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •