Results 1 to 6 of 6

Thread: kernel panic

  1. #1
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    9

    Smile kernel panic

    hi i am trying to install backtrack on my hda i followed the official guide on the backtrack site but i am still having problems mainly: lilo works and it gets to the backtrack screen but than gives me the
    kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(3,3)
    error
    any ideas why this is happening? and how to fix this? i have read that this error is associated with lilo configured incorrectly it this is the case how do i configure it correctly? and what commands would i use?

    thanks in advance

  2. #2
    Junior Member AnActivist's Avatar
    Join Date
    Apr 2009
    Posts
    77

    Default

    Try posting your lilo.conf file/check to see if it looks like other ones that have been posted around the forums. This is what mine looks like:
    Code:
    lba32
    boot=/dev/sda
    prompt
    timeout=60
    change-rules
    reset
    vga=791
    image = /boot/vmlinuz
            root = /dev/sda2
            label = Backtrack
    
    image = /mnt/sda1/vmlinuz
            root = /dev/sda1
            label = ubuntu
            initrd = /mnt/sda1/initrd.img
    Hope this helps you.

  3. #3
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    9

    Default

    lba32
    boot=/dev/hda
    change-rules
    reset
    prompt
    timeout=50
    root=/dev/hda2

    #bunch of comments

    vga=0x317

    image=/boot/vmlinuz
    label="BT4"
    read-only
    initrd=/boot/splash.initrd
    append=quiet
    other=dev/hda1
    label=win
    table=/dev/hda




    there thats it thx for ur help

  4. #4
    Junior Member AnActivist's Avatar
    Join Date
    Apr 2009
    Posts
    77

    Default

    No problem, I'm glad it worked out.

  5. #5

    Default

    after you modified your lilo.conf file, did you run "lilo -v" to incorporate the changes?

  6. #6
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    9

    Default

    lol thx but its still not working=) any ideas?
    i have used pretty much every option root=/dev/hda
    or do i need to change boot=/dev/hda?

    YES W00T w00t it works thx for the lilo -v tip
    i didnt do that after i played with the conf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •