Results 1 to 5 of 5

Thread: Acer Aspire One

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    4

    Default Acer Aspire One

    Hello everyone, this is my first post. If there are any issues with it, please let me know and I will learn and correct future posts accordingly.

    I am currently attempting to run BT3 USB distro.

    This is what I have tried, using the information I obtained from various posts. This should describe my problem pretty clearly.


    bt ~ # wlanconfig
    usage: wlanconfig athX create [nounit] wlandev wifiY
    wlanmode [sta|adhoc|ap|monitor|wds|ahdemo] [uniquebssid]
    usage: wlanconfig athX destroy
    usage: wlanconfig athX list
    [active|ap|caps|chan|freq|keys|scan|sta|wme]

    bt ~ # iwconfig
    lo no wireless extensions.

    bt ~ # kismet -c madwifi_g
    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces
    (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    FATAL: Illegal card source line 'madwifi_g'
    Done.

    bt ~ # kismet -c wifi0
    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces
    (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    FATAL: Illegal card source line 'wifi0'
    Done.

    bt ~ # kismet -c madwifi
    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces
    (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    FATAL: Illegal card source line 'madwifi'
    Done.

    When I attempt opening system>>>system information>>>network interfaces, I am returned with the following output:

    Name IP Address Network Mask Type State HWaddr

    lo 127.0.0.1 255.0.0.0 Loopback Up 00:00:00:00:00:00


    KWifi Manager shows 'No Interface'


    System>>>Settings>>>Internet and Network>>>Wireless Network
    immediately pops up 'Unable to autodetect wireless interface

    My touchpad also does not work, but that is /minor/ in comparison to the wireless network card not working. For those not familiar with the Acer Aspire One, here are the spec's:

    Intel Atom 1.05GHz
    1GB RAM
    Atheros AR5007EG Wireless Network Adaptor
    Windows XP is the standard OS

    Based on all of this, even if I can get a fix, rebooting will null all the work I have done. I will continue to search for an answer, but the only option may be somehow partioning my HD and installing BT with a dual boot.

    Thanks in advance!

  2. #2
    Good friend of the forums
    Join Date
    Feb 2010
    Posts
    328

    Default

    I have on my aspire one
    ath0 ( that athors onboard card ) you should just beableto

    airmon-ng start ath0

    something like that I dont have the laptop with me

  3. #3

    Default

    OP: Any reason you're not using BT4 instead of BT3? Reason I ask is that I have an Acer Aspire One, and BT4 on a USB worked fine "out of the box".

  4. #4
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    4

    Default

    Quote Originally Posted by cybrsnpr View Post
    OP: Any reason you're not using BT4 instead of BT3? Reason I ask is that I have an Acer Aspire One, and BT4 on a USB worked fine "out of the box".
    Thanks for the idea. I went ahead and partitioned my thumbdrive to a persistent BT4 distro. Touchpad works, but still no lo or wifi.

    iwconfig returns the following:
    lo no wireless extensions.

    eth0 no wireless extensions.

    wifi0 no wireless extensions.


    eth0 returns data, but that is not quite what I'm looking for.

  5. #5
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    4

    Default

    Quote Originally Posted by operat0r View Post
    I have on my aspire one
    ath0 ( that athors onboard card ) you should just beableto

    airmon-ng start ath0

    something like that I dont have the laptop with me
    This was exactly right. For all others who get an Acer Aspire One in the future:

    To configure your wireless, do the following:

    airmon-ng
    Stop all athX devices, leaving only eth0 lo and wifi0.
    Then, if you choose to modify your connection properities, ie, MAC address, do so to wifi0.

    airmon-ng start wifi0

    ^^^^the above will create an athX connection, whose parent is wifi0, carrying over the changes made.

    airodump-ng athX

    ^^^^the above will show all potential connections within range of your laptop.

    I hope this was helpful to anyone in the future who invests in the Acer Aspire One.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •