Results 1 to 5 of 5

Thread: macchanger problem 06:11:22:33:44:55

  1. #1
    Member imported_onryo's Avatar
    Join Date
    Apr 2009
    Posts
    109

    Default macchanger problem 06:11:22:33:44:55

    I am going to have seizures. This is so damn easy and yet it wont work. It worked before for f*** sake! macchanger will not put my ath0 into 00:11:22:33:44:55 the way it should when I go into mon mode. As far as I know I am doing it the way I always did it with my Atheros AR5001x chip. Same old madwifi drivers and all in BT4.

    # airmon-ng stop ath0
    # ifconfig wifi0 down
    # macchanger --mac 00:11:22:33:44:55 wifi0
    # airmon-ng start wifi0


    Then a quick ifconfig to see what I got and and WTF!

    ath0 HWaddr 00-11-22-33-44-55-40-F1-00-00-00-00-00-00-00-00

    Then when I go back into man mode I get some weird 06: as the first numbers in my mac! Sure I can surf with it but still!

    ath0 Link encap:Ethernet HWaddr 06:11:22:33:44:55

    What the heck is this?

    All the best
    onryo
    Let me explain officer, I am not a hacker. I am a security tester of sorts!

  2. #2
    Senior Member streaker69's Avatar
    Join Date
    Jan 2010
    Location
    Virginville, BlueBall, Bird In Hand, Intercourse, Paradise, PA
    Posts
    3,535

    Default

    First hit when googling: 06:11:22:33:44:55

    http://madwifi-project.org/ticket/2249
    A third party security audit is the IT equivalent of a colonoscopy. It's long, intrusive, very uncomfortable, and when it's done, you'll have seen things you really didn't want to see, and you'll never forget that you've had one.

  3. #3
    Member imported_onryo's Avatar
    Join Date
    Apr 2009
    Posts
    109

    Default

    Yeah I saw that too but the weird thing was that it WAS working just a few days ago and now this. I have been playing around with SSLstrip and now I have this problem. Nothing has been updated etc. I am not sure the two go hand in hand but still.

    All the best
    onryo
    Let me explain officer, I am not a hacker. I am a security tester of sorts!

  4. #4

    Default

    Quote Originally Posted by onryo View Post
    I am going to have seizures. This is so damn easy and yet it wont work. It worked before for f*** sake! macchanger will not put my ath0 into 00:11:22:33:44:55 the way it should when I go into mon mode. As far as I know I am doing it the way I always did it with my Atheros AR5001x chip. Same old madwifi drivers and all in BT4.

    # airmon-ng stop ath0
    # ifconfig wifi0 down
    # macchanger --mac 00:11:22:33:44:55 wifi0
    # airmon-ng start wifi0


    Then a quick ifconfig to see what I got and and WTF!

    ath0 HWaddr 00-11-22-33-44-55-40-F1-00-00-00-00-00-00-00-00

    Then when I go back into man mode I get some weird 06: as the first numbers in my mac! Sure I can surf with it but still!

    ath0 Link encap:Ethernet HWaddr 06:11:22:33:44:55

    What the heck is this?

    All the best
    onryo
    Assign your bogus MAC address to wifi0, then use wlanconfig to create ath0. When you do, specify the "uniquebssid" flag at the end.

    Code:
    wlanconfig ath create wlandev wifi0 wlanmode monitor uniquebssid
    (I think this is the correct syntax, I haven't needed to do this for a while)

  5. #5
    Member imported_onryo's Avatar
    Join Date
    Apr 2009
    Posts
    109

    Default AWUS036H macchanger

    Quote Originally Posted by cybrsnpr View Post
    Assign your bogus MAC address to wifi0, then use wlanconfig to create ath0. When you do, specify the "uniquebssid" flag at the end.

    Code:
    wlanconfig ath create wlandev wifi0 wlanmode monitor uniquebssid
    (I think this is the correct syntax, I haven't needed to do this for a while)
    Thx cybersnpr!
    It worked that is the good news! Wanna know the better news! Just got myself an Alfa AWUS036H 500mW card. Funny, the commands I posted for my Atheros don's seem to change my MAC at all when I go into mon mode. Doing it like this.

    # airmon-ng stop wlan0
    # ifconfig mon0 down
    # macchanger --mac 00:11:22:33:44:55 mon0
    # airmon-ng start mon0


    also the commands to get out of mon mode do not work with these drivers.

    # airmon-ng stop wlan0
    # wlanconfig wlan create wlandev mon0 wlanmode sta


    ---update---
    Scratch this. One of the most retarded things I have ever wrote!
    A quick read at aircrack-ng explained all of this quite well :P

    Thx
    Onryo
    Let me explain officer, I am not a hacker. I am a security tester of sorts!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •