hi bt fellows,

anyone had luck to compile successfully the latest compat-wireless drivers on bt4?

I do need it for my cardbus ubiquiti sr71c, as some have already posted the included ath9k is to old.

that's what you get if you insert the card with the original bt4 ath9k driver:
>>
pcmcia_socket pcmcia_socket0: pccard: CardBus card inserted into slot 0
pci 0000:06:00.0: reg 10 32bit mmio: [0x000000-0x00ffff]
pci 0000:06:00.0: PME# supported from D0 D3hot
pci 0000:06:00.0: PME# disabled
ath9k 0000:06:00.0: enabling device (0000 -> 0002)
ath9k 0000:06:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
ath_init: unable to attach hardware; HAL status 4294967277
ath9k 0000:06:00.0: PCI INT A disabled
>>

unfortunately i've problem to compile the latest compat drivers :-(
The compile error is within:
compat-wireless-xxxx/drivers/net/wireless/libertas//if_sdio.c
>> error: ‘SDIO_DEVICE_ID_MARVELL_8688WLAN’ undeclared here (not in a function)
>>

thx and useful help is appreciated!
brtw2003

temporary solution:

disable libertas in the makefile

BUT after installing new wireless subsystem all existing onces now broken, like
iwlang etc - deinstalled compat-wireless and running with old onces again :-(

i hope somone with in-depth wireless driver knowledge knows how
to fix that in bt4 and get finally 802.11n cards with AR9160 working.

rgds
brtw2003