Results 1 to 7 of 7

Thread: Kismet on Atheros [ AR2413 ] - Acer Aspire 5100 Laptop

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    3

    Default Kismet on Atheros [ AR2413 ] - Acer Aspire 5100 Laptop

    I've been trying to learn WEP cracking for obvious security reasons / I have some free time. There seems to be a problem when I try running kismet though as follows:
    Code:
    root@bt:/bin# kismet
    Launching kismet_server: //usr/bin/kismet_server
    Suid priv-dropping disabled.  This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
    Source 0 (intel): Enabling monitor mode for iwl3945 source interface wlan0 channel 6...
    FATAL: GetIFFlags: interface wlan0: No such device
    Done.
    At first it was not showing any kind of connection from the device so i used

    Code:
    modprobe ath5k
    sudo ip link set ath0 up
    sudo iwconfig ath0 essid any
    Still i'd receive the same error as above. I'm sure I'm doing something completely wrong.The compatability list says this device is support but not right away [something is disabled apparently and I'm guessing I'm missing it..]

    Here's some additional information; and thank you in advance!

    Code:
    root@bt:/bin# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wifi0     no wireless extensions.
    
    ath0      IEEE 802.11g  ESSID:"dd-wrt"  Nickname:""
              Mode:Managed  Frequency:2.437 GHz  Access Point: 00:13:10:F8:2E:44
              Bit Rate=11 Mb/s   Tx-Power:16 dBm   Sensitivity=1/1
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=31/70  Signal level=-65 dBm  Noise level=-96 dBm
              Rx invalid nwid:1663  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Code:
    06:02.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
            Subsystem: AMBIT Microsystem Corp. Device 0418
            Flags: bus master, medium devsel, latency 96, IRQ 22
            Memory at b0200000 (32-bit, non-prefetchable) [size=64K]
            Capabilities: [44] Power Management version 2
            Kernel driver in use: ath_pci
            Kernel modules: ath5k, ath_pci

  2. #2
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    4

    Default

    Hey man,

    We have the same laptops but I am wondering why you have Atheros AR2413? I own an Acer 5100 but I have Atheros AR5005G. Are you using a different device for Wireless?

  3. #3
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by personal View Post
    Hey man,

    We have the same laptops but I am wondering why you have Atheros AR2413? I own an Acer 5100 but I have Atheros AR5005G. Are you using a different device for Wireless?
    Because the prices of the hardware changes generally on a daily basis, as such the OEM's tend to go with a cheaper option that way they can continue to charge you the same price, but keep a bigger portion of said money as profit. Or they just ran out of the 'other' one, and had to go with a replacement.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  4. #4

    Default

    OP: Change the source= line in the /etc/kismet/kismet.conf file to reflect your specific driver and interface:

    Code:
     source=madwifi_g,ath0,ath0
    If your card can cover 802.11a, you may want to change the first field to reflect accordingly. All this information is covered in the kismet documentation.

  5. #5
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    3

    Default

    Okay I tried doing the

    source=madwifi_g,ath0,ath0

    fix, however, I'm getting a new error now.

    Code:
    Launching kismet_server; //usr/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon- VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
    Source 0 (ath0): Enabling monitor mode for madwifi_g source interface ath0 channel 6...
    WARNING: Could not get mode of vap ath0::wifi0, skipping
    ERROR: Unable to create VAP; Operation not supported
    ERROR: Unable to create monitor-mode VAP
    WARNING: ath0 appears to not accept the Madwifi-NG controls. Will attempt to configure it as a standard Madwifi-old interface. If you are using madwifi-ng, be sure to set the source interface to the wifiX control interface, NOT athX
    FATAL: 'get_mode' does not return interger parameters.
    Done.
    So I guess my question is now - how would i put the card from ath0 to wifi0 ?

    Thank you in advance!

  6. #6

    Default

    Didn't realize you are using ath5k drivers. Change your source from madwifi_g to ath5k.

    Again, it's all in the DOCUMENTATION, specifically under "Capture Sources"

  7. #7
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    3

    Default

    Quote Originally Posted by cybrsnpr View Post
    Didn't realize you are using ath5k drivers. Change your source from madwifi_g to ath5k.

    Again, it's all in the [omitted], specifically under "Capture Sources"
    Worked perfectly. Thank you very much cybrsnpr!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •