Results 1 to 4 of 4

Thread: BT4 Kismet "Illegal Card Source"

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    2

    Default BT4 Kismet "Illegal Card Source"

    Hi all,

    I just downloaded and liveCD'd BT4, after some searching and other such fun I came across a tutorial for Kismet. For a while now I've been trying to use it but keep running into various errors, I've tried my laptop and server(With wireless card) but kismet seems to hate both.

    First, of course, I just went into the terminal and wrote Kismet, and it told me that there was no such device wlan0, fair enough.
    iwconfig told me that eth1 was the thing I should try, so I tried:
    kismet -c eth1

    Which produced: Illegal card source line 'eth1'
    I then tried "airmon-ng start eth1" which put eth1 into monitor mode, I tried the kismet -c eth1 command again with the same result(I didn't expect this to do much but it was worth a shot).

    I was going to modify the kismet.conf but after looking around I found that the conf file isn't in it's default location ( /usr/local/etc/kismet.conf ), and I couldn't find it.

    I have looked through documentation and various tutorials on the web but can't find a solution, I think the problem is that perhaps 'eth1' normally refers to an ethernet port, so perhaps bt isn't picking up my wireless card. Here's the info that airmon-ng start eth1 gives me:

    Interface: eth1
    Chipset: intel 2100B
    Driver: ipw2100 (Monitor mode enabled)

    Thanks for any help.

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Besides how do I get my wifi to work in vmware this may be the most asked and most covered thing on this forum. Try a little searching.

    find / -name kismet.conf will find your file

  3. #3
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    2

    Default

    As stated, I'm using a liveCD, is there a way of allowing it to work without putting it in a VM / Installing the OS onto my HDD?

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Quote Originally Posted by Makeshift27015 View Post
    As stated, I'm using a liveCD, is there a way of allowing it to work without putting it in a VM / Installing the OS onto my HDD?
    Yes you have to edit your kismet.conf and add the proper card source. Its all in the kismet documentation. Try Reading the manual next time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •