I'm not sure how serious an issue this is. I had it happen a while ago for something I was trying to compile for myself, but i have reproduced it in envy-ng while trying to install video drivers for ATI or nvidia.

Ubuntu forums refer to uname -r for getting your kernel version, BT4 replies "2.6.28.1", and the most recent kernel headers in aptitude appear to be for 2.6.27-11.

Has anyone else had a conflict with this? If not I'm curius why I'm getting this error.

I've done a harddrive install as per SuspectZero's script found in the HowTo's forum. It was a move-over from a persistant USB boot. But I've tested it from the livecd directly also and got the same issue with envy ( I unfortunately cannot recall what gave me the error first ).