Results 1 to 7 of 7

Thread: How to setup RT2860 (EEE 901/1000h) for WPA-PSK (DHCP)

  1. #1
    Just burned his ISO
    Join Date
    Mar 2009
    Posts
    2

    Default How to setup RT2860 (EEE 901/1000h) for WPA-PSK (DHCP)

    This might be very obvious, but since I've just spent an unfair amount of time trying to figure this out, I might as well put it on paper.

    STEP 1: Downloading, extracting, compiling, installing and activating the driver:

    Code:
    wget h t t p://w w w.ralinktech.com.tw/data/drivers/2008_0918_RT2860_Linux_STA_v1.8.0.0.tar.bz2
    tar -xjf 2008_0918_RT2860_Linux_STA_v1.8.0.0.tar.bz2
    cd 2008_0918_RT2860_Linux_STA_v1.8.0.0
    make && make install
    modprobe rt2860sta
    This was taken from Arie1's post: showthread.php?t=20554. Thanks a lot!

    NOTE: You are not using any kind of network manager for this. You can read up on this here: h t t p://wiki.debian.org/WiFi/HowToUse


    STEP 2: Creating the PSK-string, which you will use later:

    Code:
    wpa_passphrase yourssid yourpassphrase
    Example:

    Code:
    wpa_passphrase linksys myp4ssw0rd
    The output will look like this:

    Code:
    root@bt:~# wpa_passphrase linksys myp4ssw0rd
    network={
            ssid="linksys"
            #psk="myp4ssw0rd"
            psk=96b9e5a1ac253ac8288d79f75fb0d616e9e92717dd651fc0e126e52475eb42d3
    }
    Copy the long string marked with red.


    STEP 3: Setting up /etc/network/interfaces.

    Unless you've somehow added the wireless interface otherwise, you're going to add it now. First you need to open the interfaces file:

    Code:
    nano /etc/network/interfaces
    Now add this at the end of the file:

    Code:
    # The wireless network interface
    auto ra0
    iface ra0 inet dhcp
    If this is already in place, it means that it has somehow been configured otherwise, which is not a problem and you should just proceed.

    Now you add this after the wireless interface which you just added:
    Code:
        wpa-ssid yourssid
        wpa-psk yourpskstring
    Example:

    Code:
    # The wireless network interface
    auto ra0
    iface ra0 inet dhcp
        wpa-ssid linksys
        wpa-psk 96b9e5a1ac253ac8288d79f75fb0d616e9e92717dd651fc0e126e52475eb42d3

    STEP 4: Restarting networking

    Code:
    /etc/init.d/networking restart
    That should do it!

    The pros and cons of this method is that it only adds two lines of text to your system (apart from the obvious wpa_supplicant), but this way is not optimal if you use more than one access point. For that there's the wpa_supplicant.conf way. Read about it here: h t t p://wiki.debian.org/rt2860sta#wpasupplicant.


    UPDATE! Definite working solution!

    If step 1-4 doesn't work for you, here's the confirmed working solution:

    NOTE: You can try the above method before doing this, it won't conflict.

    Code:
    wget h t t p://http.us.debian.org/debian/pool/non-free/r/rt2860-source/rt2860-source_1.8.0.0-3_all.deb
    dpkg -i rt2860-source_1.8.0.0-3_all.deb
    apt-get install module-assistant debhelper
    m-a prepare
    m-a a-i rt2860
    What it does:
    • downloads the source in .deb form (mirrors can be found here: h t t p://packages.debian.org/squeeze/all/rt2860-source/download)
    • installs two small but very useful programs: module assistant and debhelper
    • updates module assistant
    • complies and installs the driver from the .deb file with module assistant


    Since I'm not sure if module assistant activates the driver you'll do it yourself, just to be sure:

    Code:
    modprobe rt2860sta
    And lastly you restart networking:

    Code:
    /etc/init.d/networking restart
    Why this works is probably because of some settings that either dpkg or module-assistant sets. I don't know, but it worked for me (EEE 1000h).

  2. #2
    Junior Member
    Join Date
    Mar 2009
    Posts
    77

    Default re

    in my case it dosn't work.
    the driver is set uo correctly. with iwlist i can see my network.
    but if i ran /etc/init.d/networking start it's in a loop with setting up ra0

    it finds no dhcp server.
    any ideas?

  3. #3
    Just burned his ISO
    Join Date
    Mar 2009
    Posts
    2

    Default

    The main post has been updated. Maybe it will work for you now? I hope

  4. #4
    Just burned his ISO
    Join Date
    Mar 2009
    Posts
    1

    Default

    I'm using BT4 beta as a live usb drive, and since I can't format the drive properly to ext2, I always have to configure everything when I reboot my eee. That's why I've written two little bash files because I'm too lazy to do it every damn time I boot into BT
    You can download an archive containing the files and the driver here: h t t p : / / w w w . filefactory . com/file/af7a68b/n/eee1000h_wifi-bash_tar_bz2
    Just untar everything on your usb drive (I assumed it's sdb1, if not you have to modify the "wifi_driver" script!), chmod +x the scripts if you need to and there you go.

    Here you have the content of the two bash script files:
    wifi_driver
    #! /bin/bash
    cp /mnt/sdb1/2008_0918_RT2860_Linux_STA_v1.8.0.0.tar.bz2 /root/2008_0918_RT2860_Linux_STA_v1.8.0.0.tar.bz2

    cd /root

    tar xvjf 2008_0918_RT2860_Linux_STA_v1.8.0.0.tar.bz2
    cd 2008_0918_RT2860_Linux_STA_v1.8.0.0

    make
    make install
    cd os/linux
    insmod rt2860sta.ko

    ifconfig ra0 up
    and the wifi_connect.sh
    # !/bin/bash

    rmmod rt2860sta
    modprobe rt2860sta

    ifconfig ra0 down
    ifconfig ra0 up

    iwpriv ra0 get_site_survey

    echo "Type the SSID of the WLAN you wish to connect to"
    read S

    stty -echo
    echo "Now type the WPA-Key of the Network"
    read K
    stty echo

    iwpriv ra0 set NetworkType=Infra
    iwpriv ra0 set AuthMode="WPAPSK"
    iwpriv ra0 set EncrypType="TKIP"
    iwpriv ra0 set SSID="$S"
    iwpriv ra0 set WPAPSK="$K"

    dhclient ra0
    hope that helped someone you are of course always welcome to write me a feedback

  5. #5
    Junior Member
    Join Date
    Mar 2009
    Posts
    77

    Default

    Didn't work for me either.
    Installed it, then compield with m-a a-i rt2860
    worked fine.
    then tried modprob
    no such file!
    tryed ifconfig ra0 up
    unknown interface
    any ideas?

  6. #6
    Junior Member
    Join Date
    Mar 2009
    Posts
    77

    Thumbs up got it

    Ok it's running...

    That's how i do it:

    Method 1, but BEFOR make && make install edit the following file

    in [driverfolder]/os/linux/config.mk modify

    ** Build for being controlled by NetworkManager
    set
    HAS_WPA_SUPPLICANT=y
    and
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y


    then go on with modprobe blabla and edit the /etc/networking/interfaces
    thats it.

    Works for me!

  7. #7
    Junior Member
    Join Date
    Mar 2009
    Posts
    39

    Default

    eh ive been at this for like 8 hours(yes, i have alot of time on my hands) and still not working. i got the driver setup it sees the AP but it cant connect and when i look at the iwconfig and ifconfig it says that encryption is set to no..how can i fix this...its pissing me off....

    EDIT= NVRMND it was my wifi..wpa psk ccmp doesnt work with this card...

    EDIT: hey they updated the driver to 2.1.1.0 now the wpa ccmp will work on bt4 and bt3
    They ran this hack in V.M.O., so I'm isolating the A.P.I., and just booting the host. -Matthew Farrell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •