Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: rt73 driver not work (Linksys WUSB54GC

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Oct 2008
    Posts
    4

    Exclamation rt73 driver not work (Linksys WUSB54GC

    Hmm ifconfig -a shows no rausb0 like I used to get on bt3. The rt73 module _is_ loaded however. lsmod displays:
    Code:
    Bus 001 Device 005: ID 13b1:0020 Linksys WUSB54GC 801.11g Adapter [ralink rt73]
    I really had no problems at all injecting/monitoring with this USB dongle on bt3
    and the fact that the module is still loading but not working perplexes me.
    h x x p://backtrack.offensive-security.com/index.php/HCL:Wireless#Linksys_WUSB54GC <-- I'm using that :]

  2. #2
    Just burned his ISO
    Join Date
    Oct 2008
    Posts
    4

    Default

    Fixed the prob: it was a faulty USB port :X


    Delete me :P

  3. #3
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    2

    Default

    How resolve this problem is a bug ?
    I have the same usb card and dont work is the same problem.

  4. #4
    Senior Member Shatter's Avatar
    Join Date
    Jan 2010
    Posts
    192

    Default

    I believe the BT4 version of the driver module is called rt73usb.
    I have the card in me head, but you have the memory problems?

  5. #5
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    2

    Default

    In bt4 yes it is, in my case yes rt73usb but the usb card dont work Linksys WUSB54GC
    the message of ifconfig is : rausb0 ERROR while getting interface flags :No such device
    In the bt3 dont work the injects packets with areplay --test rausb0

    and the module is listed in lsmod.

    Help me ....

    Thanks

  6. #6
    Member DigiP's Avatar
    Join Date
    Jan 2010
    Location
    NJ
    Posts
    57

    Default

    I have the same WUSB54GC card.(Make sure its not WUSB54GSC as the one with the S is SpeedBoost, and not compatible!). What I did was install the custom rt73 drivers. Ifconfig the default one down and rmmod it(I think it comes up as wlan0 in bt4, can't remember). Then install the ones from this site: http://homepages.tu-darmstadt.de/~p_larbig/wlan/

    http://homepages.tu-darmstadt.de/~p_...-3.0.2.tar.bz2

    Once the enhanced driver is installed, do a modprobe rt73, then you should have back your rausb0 default hardware id and can then do all the normal settings for the card, like iwpriv forceprism 1, other options, etc.

  7. #7
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    14

    Default

    I've patched the driver with rt73-k2wrlz-3.0.2.tar.bz2.
    Before i did i was using wlan0 then after the patch i was using rausb0, but logged on today and now im back to using wlan0.
    I'm Backtrack 4 beta via vmware workstation. RT73 is a D-LINK DWA110.
    Can anyone just shed some light on this.
    Thanks in advance if i sound like an idiot.

  8. #8
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    1

    Default

    Hi,

    I hope it will help. I had the same pb using BT4 in VMWare with a WUSB54GC dongle.
    When I turned my USB in monitor mode, my interface name was 'mon0' in monitor mode, and not 'wlan0' as before.

    Injection works perfectly with 'mon0' interface name

    Cheers

  9. #9
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    14

    Default

    Cheers, every bit of info helps.

  10. #10
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    3

    Default

    I'm also using the WUSB54GC v. 3 USB dongle and BT4 beta in VMWare, and despite strictly following many of the instructions posted (here, aircrack forum, and more) I cannot get it to appear after an 'airmon-ng' or even in 'iwconfig'. The device works in Windows and VMWare claims to have taken control, I just can't seem to get a grip on it. I even tried the drivers recommended from homepages.tu-darmstadt.de.

    ...but these do not work. I had limited success installing the 'apocolipse' package.

    Any tips or recommended guides?

    Thanks so very much.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •