Have a look at the History here http://www.remote-exploit.org/codes_hotspotter.html
As it seams microsoft has patched Xp since sp1 to not bring the client from a secure EAP/TLS network to an insecure one without any warnings from the operating system.
So probably even the official 1.0 release of airbase will not do that!!!!