Results 1 to 9 of 9

Thread: [FIX] Hydra

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Mar 2009
    Posts
    3

    Post [FIX] Hydra

    When I tried to use Hydra against a SSH service and I get the next error: Error: Compiled without LIBSSH support, module not available!

    The trick was downloading the libssh compile it and installing it qith the defaults from there

    Code:
    wget 0xbadc0de.be/libssh/libssh-0.11.tgz
    Then I downloaded the hydra sources from here

    Code:
    wget freeworld.thc.org/releases/hydra-5.4-src.tar.gz
    I modified the Makefile:

    in the line 3 I changed the next 2 lines like this

    Code:
    XDEFINES= -DLIBOPENSSL -DLIBSSH
    XLIBS= -lssl -lssh -lcrypto
    and in the line 38 I changed the next 2 lines like this

    Code:
    BIN = hydra.ssh
    BINUNIX = hydra.ssh pw-inspector
    then "make all install"

    and the new Hydra bin with ssh support is called hydra.ssh. You can leave the Makefile as it and you will overwrite the original hydra bin.

    Here is my complete Makefile:

    Code:
    pastebin.com/fd5499db
    Greets,
    ..:: Ch0ks ::..

  2. #2
    Just burned his ISO
    Join Date
    Dec 2008
    Posts
    3

    Default

    Ok I don't know what I am doing wrong here. Sorry I was going to post what errors I got but I can't use the code tags yet.... Here is some errors I get from when I try to make install in hydra

    hydra-ssh2.c:93: error: ‘SSH_ERROR’ undeclared (first use in this function)
    hydra-ssh2.c:93: error: (Each undeclared identifier is reported only once
    hydra-ssh2.c:93: error: for each function it appears in.)


    Here is how I get there in shorted steps ... Maybe I did something wrong while installing

    i wget all the files needed
    tar zxvf all the filles
    cd into the libssh folder
    ./configure
    make
    make install
    then cd into the hydra folder
    ./configure
    copy and paste the file provided above
    make
    make install

    it still does not work... I've also tried using medusa but I get an auth error after 3 attempts I tried abit to fix that one but I figured to stick to one program to get working.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2008
    Posts
    17

    Default

    Quote Originally Posted by ch0ks View Post
    When I tried to use Hydra against a SSH service and I get the next error: Error: Compiled without LIBSSH support, module not available!

    The trick was downloading the libssh compile it and installing it qith the defaults from there

    Code:
    wget 0xbadc0de.be/libssh/libssh-0.11.tgz
    Then I downloaded the hydra sources from here

    Code:
    wget freeworld.thc.org/releases/hydra-5.4-src.tar.gz
    I modified the Makefile:

    in the line 3 I changed the next 2 lines like this

    Code:
    XDEFINES= -DLIBOPENSSL -DLIBSSH
    XLIBS= -lssl -lssh -lcrypto
    and in the line 38 I changed the next 2 lines like this

    Code:
    BIN = hydra.ssh
    BINUNIX = hydra.ssh pw-inspector
    then "make all install"

    and the new Hydra bin with ssh support is called hydra.ssh. You can leave the Makefile as it and you will overwrite the original hydra bin.

    Here is my complete Makefile:

    Code:
    pastebin.com/fd5499db
    Greets,
    ..:: Ch0ks ::..
    this did not work..changed the make file ...still no joy.. after all this typing hydra gives an empty prompt.

  4. #4
    Just burned his ISO
    Join Date
    May 2009
    Posts
    1

    Default

    Ch0ks,

    I am new to Linux. Could you, or someone, please elaborate on this...
    Quote Originally Posted by ch0ks View Post
    I modified the Makefile:

    in the line 3 I changed the next 2 lines like this
    Where will I find the "Makefile", so that I can Edit it.

    Thanks.
    Tad' ta' daaaarn! SuperN00b to the rescue!

  5. #5

  6. #6
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    22

    Default

    This worked for me. Taken from Tux Training » Blog Archive » HOWTO: Install THC-Hydra 5.4 in Ubuntu Intrepid Ibex
    Make sure you have the ssh package installed, build-essentials, and the 2.0 gtk (I dunno if that one really affected anything or not, but I did it and it's working now...)

    Download the hydra source, untar it, etc.

    ./configure

    nano Makefile

    Edit the following lines to look like this, POSTGRES appears to be screwing stuff up in my case.

    XDEFINES= -DLIBOPENSSL -DLIBSSH
    XLIBS= -lssl -lssh -lcrypto

    Ctrl-O, Ctrl-X

    make

    make install

    Worked like a champ for me on my HDD install.

  7. #7
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    18

    Default

    I also had to move the compiled libssh.so file into /usr/lib to get this working

  8. #8
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    2

    Default it worked

    but after the whole jive i run both the command line and gui hydra from

    Code:
    /usr/bin
    or you can run

    Code:
    locate hydra

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •