Results 1 to 6 of 6

Thread: bt4 vmware

  1. #1
    Just burned his ISO alexkbee's Avatar
    Join Date
    Feb 2010
    Posts
    3

    Unhappy bt4 vmware

    hi all..ok i have tried over a week now to get this thing goin an no luck ugh..anyways i have win xp for my host machine an running bt4 beta with vmware 7 i have bridged my connection an can get online check out webpages but when i start getting in to airmon-ng all i get is

    root@bt:~# airmon-ng


    Interface Chipset Driver


    root@bt:~#

    an i have also tired "lspci"

    root@bt:~# lspci
    00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 01)
    00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 01)
    00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 08)
    00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
    00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
    00:07.7 System peripheral: VMware Inc Virtual Machine Communication Interface (rev 10)
    00:0f.0 VGA compatible controller: VMware Inc Abstract SVGA II Adapter
    00:10.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 01)
    00:11.0 PCI bridge: VMware Inc PCI bridge (rev 02)
    00:15.0 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:15.1 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:15.2 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:15.3 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:15.4 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:15.5 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:15.6 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:15.7 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:16.0 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:16.1 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:16.2 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:16.3 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:16.4 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:16.5 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:16.6 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:16.7 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:17.0 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:17.1 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:17.2 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:17.3 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:17.4 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:17.5 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:17.6 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:17.7 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:18.0 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:18.1 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:18.2 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:18.3 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:18.4 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:18.5 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:18.6 PCI bridge: VMware Inc Device 07a0 (rev 01)
    00:18.7 PCI bridge: VMware Inc Device 07a0 (rev 01)
    02:00.0 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB
    02:01.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 10)
    02:02.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 02)
    02:03.0 USB Controller: VMware Inc Abstract USB2 EHCI Controller
    root@bt:~#

    i'm stumped whatever info i can give u to help me i'll do.. to get this working!!

  2. #2
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default Re: bt4 vmware

    Read the FAQ, check the entry related to wireless devices in virtual machines.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  3. #3
    Just burned his ISO alexkbee's Avatar
    Join Date
    Feb 2010
    Posts
    3

    Cool

    ahhh..alright think i got it! have to make more then 1 virtual machine an make the first on bridge an others custom on vmnet
    thx that was a great help! cheerz to it.. if i have any other questions i'll be sure to post them
    later.. dude

    i ended up putting bt4 final iso on an everything seems to be working fine now..

    Hi i'm having problems hooking up wireless maybe someone might beable to tell me what the problem is

    Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870 Wireless Adapter

    lsmod
    Module Size Used by
    vmxnet 17624 0
    rt3070sta 512500 1
    ipv6 239348 10
    sbs 10940 0
    video 18024 0
    output 2388 1 video
    sbshc 4500 1 sbs
    cpufreq_conservative 7048 0
    cpufreq_powersave 1268 0
    cpufreq_performance 1300 0
    cpufreq_ondemand 7080 0
    cpufreq_stats 4728 0
    freq_table 3476 2 cpufreq_ondemand,cpufreq_stats
    ppdev 7096 0
    vmblock 12436 1
    vsock 39040 0
    vmmemctl 8380 0
    vmhgfs 51240 0
    pvscsi 14308 0
    acpiphp 21288 0
    iptable_filter 2324 0
    ip_tables 10916 1 iptable_filter
    x_tables 13592 1 ip_tables
    lp 9412 0
    snd_ens1371 21216 0
    gameport 9984 1 snd_ens1371
    snd_ac97_codec 100824 1 snd_ens1371
    ac97_bus 1364 1 snd_ac97_codec
    snd_pcm_oss 37728 0
    snd_mixer_oss 14324 1 snd_pcm_oss
    snd_pcm 67704 3 snd_ens1371,snd_ac97_codec,snd_pcm_oss
    psmouse 41732 0
    serio_raw 5016 0
    snd_seq_dummy 2424 0
    parport_pc 24292 1
    parport 30572 3 ppdev,lp,parport_pc
    snd_seq_oss 27328 0
    snd_seq_midi 5952 0
    snd_rawmidi 19488 2 snd_ens1371,snd_seq_midi
    rtc_cmos 10156 0
    snd_seq_midi_event 5972 2 snd_seq_oss,snd_seq_midi
    rtc_core 15792 1 rtc_cmos
    rtc_lib 2388 1 rtc_core
    snd_seq 47568 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    snd_timer 19068 2 snd_pcm,snd_seq
    snd_seq_device 6048 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    snd 50468 10 snd_ens1371,snd_ac97_codec,snd_pcm_oss,snd_mixer_o ss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_tim er,snd_seq_device
    soundcore 5856 1 snd
    snd_page_alloc 7836 1 snd_pcm
    intel_agp 26108 1
    vmci 27620 1 vsock
    agpgart 29356 1 intel_agp
    i2c_piix4 9796 0
    shpchp 31560 0
    evdev 9120 5
    ata_generic 4536 0
    sg 25064 0
    pata_acpi 3892 0
    fuse 53104 1

    root@bt:~# uname -r
    2.6.30.9

    Hi i'm having problems setting up my wireless if there anybody that could help would be GREAT!! i tried iwconfig for my essid an seeting up key but keeps giving me errors this is what i have so far..

    Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870 Wireless Adapter

    lsmod

    Module Size Used by
    vmxnet 17624 0
    rt3070sta 512500 1
    ipv6 239348 10
    sbs 10940 0
    video 18024 0
    output 2388 1 video
    sbshc 4500 1 sbs
    cpufreq_conservative 7048 0
    cpufreq_powersave 1268 0
    cpufreq_performance 1300 0
    cpufreq_ondemand 7080 0
    cpufreq_stats 4728 0
    freq_table 3476 2 cpufreq_ondemand,cpufreq_stats
    ppdev 7096 0
    vmblock 12436 1
    vsock 39040 0
    vmmemctl 8380 0
    vmhgfs 51240 0
    pvscsi 14308 0
    acpiphp 21288 0
    iptable_filter 2324 0
    ip_tables 10916 1 iptable_filter
    x_tables 13592 1 ip_tables
    lp 9412 0
    snd_ens1371 21216 0
    gameport 9984 1 snd_ens1371
    snd_ac97_codec 100824 1 snd_ens1371
    ac97_bus 1364 1 snd_ac97_codec
    snd_pcm_oss 37728 0
    snd_mixer_oss 14324 1 snd_pcm_oss
    snd_pcm 67704 3 snd_ens1371,snd_ac97_codec,snd_pcm_oss
    psmouse 41732 0
    serio_raw 5016 0
    snd_seq_dummy 2424 0
    parport_pc 24292 1
    parport 30572 3 ppdev,lp,parport_pc
    snd_seq_oss 27328 0
    snd_seq_midi 5952 0
    snd_rawmidi 19488 2 snd_ens1371,snd_seq_midi
    rtc_cmos 10156 0
    snd_seq_midi_event 5972 2 snd_seq_oss,snd_seq_midi
    rtc_core 15792 1 rtc_cmos
    rtc_lib 2388 1 rtc_core
    snd_seq 47568 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    snd_timer 19068 2 snd_pcm,snd_seq
    snd_seq_device 6048 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    snd 50468 10 snd_ens1371,snd_ac97_codec,snd_pcm_oss,snd_mixer_o ss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_tim er,snd_seq_device
    soundcore 5856 1 snd
    snd_page_alloc 7836 1 snd_pcm
    intel_agp 26108 1
    vmci 27620 1 vsock
    agpgart 29356 1 intel_agp
    i2c_piix4 9796 0
    shpchp 31560 0
    evdev 9120 5
    ata_generic 4536 0
    sg 25064 0
    pata_acpi 3892 0
    fuse 53104 1

    uname -r
    2.6.30.9
    Last edited by Archangel-Amael; 02-26-2010 at 01:39 PM.

  4. #4
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default Re: bt4 final wireless problems

    Im assuming you have read this right?

    Maybe you want to list the commands you used to try and setup your card and any errors you got?
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  5. #5
    Just burned his ISO alexkbee's Avatar
    Join Date
    Feb 2010
    Posts
    3

    Default

    i have no idea whats going on i'm fairly new to all this.
    so anyways i have a connection to my external wireless but i also have a wifi stick that i'm trying to set up an i can't understand what it's telling me to do..
    i checked my log an it looks alright!


    2010/02/25 21:04:38 :: ---------------------------
    2010/02/25 21:04:38 :: wicd initializing...
    2010/02/25 21:04:38 :: ---------------------------
    2010/02/25 21:04:38 :: Automatically detected wireless interface ra0
    2010/02/25 21:04:38 :: found wireless_interface in configuration ra0
    2010/02/25 21:04:38 :: setting wireless interface ra0
    2010/02/25 21:04:38 :: automatically detected wired interface eth0
    2010/02/25 21:04:38 :: found wired_interface in configuration eth0
    2010/02/25 21:04:38 :: setting wired interface eth0
    2010/02/25 21:04:38 :: found wpa_driver in configuration wext
    2010/02/25 21:04:38 :: setting wpa driver wext
    2010/02/25 21:04:38 :: found always_show_wired_interface in configuration False
    2010/02/25 21:04:38 :: found use_global_dns in configuration False
    2010/02/25 21:04:38 :: setting use global dns to False
    2010/02/25 21:04:38 :: setting use global dns to boolean False
    2010/02/25 21:04:38 :: found global_dns_1 in configuration None
    2010/02/25 21:04:38 :: found global_dns_2 in configuration None
    2010/02/25 21:04:38 :: found global_dns_3 in configuration None
    2010/02/25 21:04:38 :: setting global dns
    2010/02/25 21:04:38 :: global dns servers are None None None
    2010/02/25 21:04:38 :: found auto_reconnect in configuration True
    2010/02/25 21:04:38 :: setting automatically reconnect when connection drops
    2010/02/25 21:04:38 :: found debug_mode in configuration False
    2010/02/25 21:04:38 :: found wired_connect_mode in configuration 1
    2010/02/25 21:04:38 :: found signal_display_type in configuration 0
    2010/02/25 21:04:38 :: found dhcp_client in configuration 0
    2010/02/25 21:04:38 :: Setting dhcp client to 0
    2010/02/25 21:04:38 :: found link_detect_tool in configuration 0
    2010/02/25 21:04:38 :: found flush_tool in configuration 0
    2010/02/25 21:04:38 :: Wireless configuration file found...
    2010/02/25 21:04:38 :: Wired configuration file found...
    2010/02/25 21:04:38 :: chmoding configuration files 0600...
    2010/02/25 21:04:38 :: chowning configuration files root:root...
    2010/02/25 21:04:38 :: Using wired interface...eth0
    2010/02/25 21:04:38 :: Using wireless interface...ra0
    2010/02/25 21:04:38 :: autoconnecting... ra0
    2010/02/25 21:04:47 :: Putting interface down
    2010/02/25 21:04:47 :: Attempting to autoconnect with wired interface...
    2010/02/25 21:04:47 :: Releasing DHCP leases...
    2010/02/25 21:04:48 :: Setting false IP...
    2010/02/25 21:04:49 :: Stopping wpa_supplicant and any DHCP clients
    2010/02/25 21:04:49 :: Flushing the routing table..
    2010/02/25 21:04:49 :: Putting interface up.
    2010/02/25 21:04:49 :: Running DHCP
    2010/02/25 21:04:49 :: Internet Systems Consortium DHCP Client V3.1.1
    2010/02/25 21:04:49 :: Copyright 2004-2008 Internet Systems Consortium.
    2010/02/25 21:04:50 :: All rights reserved.
    2010/02/25 21:04:50 :: For info, please visit DHCP | Internet Systems Consortium
    2010/02/25 21:04:50 ::
    2010/02/25 21:04:51 :: Listening on LPF/eth0/00:0c:29:98:27:42
    2010/02/25 21:04:51 :: Sending on LPF/eth0/00:0c:29:98:27:42
    2010/02/25 21:04:51 :: Sending on Socket/fallback
    2010/02/25 21:04:52 :: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
    2010/02/25 21:04:53 :: DHCPOFFER of 192.168.133.128 from 192.168.133.254
    2010/02/25 21:04:53 :: DHCPREQUEST of 192.168.133.128 on eth0 to 255.255.255.255 port 67
    2010/02/25 21:04:53 :: DHCPACK of 192.168.133.128 from 192.168.133.254
    2010/02/25 21:04:54 :: bound to 192.168.133.128 -- renewal in 789 seconds.
    2010/02/25 21:04:54 :: DHCP connection successful
    2010/02/25 21:04:54 :: Connecting thread exiting.

    sry about the copy paste..

    so if anybody has a little time to show me how its done would be awesome!

    ok so i got the usb wifi stick working to get this working i typed less /var/log/wicd/wicd.log
    an goto internet then wicd clicked on that seen wireless punched in my wpa ******************* Now i am up an running
    thought i'd be nice enought to continue this post off.. an maybe it will help some ppl out
    this took me over a week to figure out!! glad thats over with... happy crackin!
    Last edited by lupin; 02-26-2010 at 08:28 AM. Reason: Merging...

  6. #6
    Junior Member
    Join Date
    Feb 2010
    Posts
    31

    Default Re: bt4 final wireless problems

    There's a thread over on the Ubuntu forums that may help. > [all variants] Install linux drivers for ralink rt2870 - Ubuntu Forums

    I've never tried to use that wireless though.

Similar Threads

  1. Replies: 6
    Last Post: 02-22-2010, 01:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •