Results 1 to 3 of 3

Thread: Broadcom: Monitor Mode Enabled?

  1. #1
    Just burned his ISO
    Join Date
    Jul 2008
    Posts
    6

    Default Broadcom: Monitor Mode Enabled?

    Hey guys, I haven't been here in awhile since my last failed attempt, but since the release of BT4, I felt the need to give it a new try. I have finally got the notorious linux broadcom drivers up and running. The only issue i have now is when i try to run airodump:

    Code:
    root@bt:~# airodump-ng --ivs -w dmp eth1
    ioctl(SIOCSIWMODE) failed: Invalid argument
    
    ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
    ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
    sure RFMON is enabled: run 'airmon-ng start eth1 <#>'
    Sysfs injection support was not found either.
    but when i do run airmon-ng i get:

    Code:
    root@bt:~# airmon-ng start eth1
    
    
    Found 4 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    -e
    PID     Name
    6369    knetworkmanager
    6481    NetworkManager
    6486    wpa_supplicant
    7225    dhclient
    Process with PID 7225 (dhclient) is running on interface eth1
    
    
    Interface       Chipset         Driver
    
    eth1            Unknown                 wl (monitor mode enabled)
    I would cry if i finally got this to work, and I feel like i'm so close. Any help is appreciated.
    Thanks in advance

  2. #2
    Just burned his ISO
    Join Date
    Mar 2009
    Posts
    9

    Default

    Hey There,

    I think the problem you have is with the ETH1 interface.
    If I'm right ETH1 is the interface for ethernet, which is a wired interface.
    You should be using a wireless interface. Type "iwconfig" to see your interfaces.
    you should be using "wifi0" or maybe "ath0" like me.
    You need to make sure monitor mode is enabled on the interface you use aswell which is listed in "iwconfig" aswell.

    yeah I could be wrong, Just thought you might have a external wifi apliance plugged to your ethernet card. Sorry.

  3. #3
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    There are mixed reports on using a propriatory binary blob but in short its not supported.

    Your best bet is to either:
    - Donate that piece of crap wireless device to b43 developers
    - Be a lab rat and test to see if you can get it going with native drivers by subscribing with b43's mailing list
    - Forget about the whole thing with it as its a piece of junk either way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •