Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Kismet Issues

  1. #1
    Just burned his ISO
    Join Date
    Mar 2009
    Posts
    1

    Default Kismet Issues

    I've been having problems getting kismet to work. I can connect via wifi to APs fine but for some reason kismet is troublesome.

    At first I got this:
    Code:
    root@bt:~# kismet
    Launching kismet_server: //usr/bin/kismet_server
    Suid priv-dropping disabled.  This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
    Source 0 (intel): Enabling monitor mode for iwl3945 source interface wlan0 channel 6...
    FATAL: GetIFFlags: interface wlan0: No such device
    Done.
    Using iwconfig I found out that my wireless card was lurking as eth1
    Code:
    root@bt:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11g  ESSID:"Removed for privacy"
              Mode:Managed  Frequency:2.412 GHz  Access Point: Removed for privacy
              Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0
              Retry limit:7   RTS thr:off   Fragment thr:off
              Encryption key:Removed for privacy   Security mode:open
              Power Management:off
              Link Quality=79/100  Signal level=-50 dBm  Noise level=-89 dBm
              Rx invalid nwid:0  Rx invalid crypt:1  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:1
    So then I tried adding eth1 as a source in the /etc/kismet/kismet.conf but i got the following message then
    Code:
    root@bt:~# kismet
    Launching kismet_server: //usr/bin/kismet_server
    Suid priv-dropping disabled.  This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    FATAL: Illegal initial channel 'eth1' specified on the sourceline for 'iwl3945'
    Done.
    Now I tried looking around the same conf file but honestly this is way out of my league now. Looking for help now.

  2. #2
    Senior Member Thorn's Avatar
    Join Date
    Jan 2010
    Location
    The Green Dome
    Posts
    1,509

    Default

    The answer you seek is in the Kismet Readme.
    Thorn
    Stop the TSA now! Boycott the airlines.

  3. #3
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by xilni View Post
    I've been having problems getting kismet to work. I can connect via wifi to APs fine but for some reason kismet is troublesome.
    Kismet is not troublesome, as indicative of the second part below.

    Now I tried looking around the same conf file but honestly this is way out of my league now. Looking for help now.
    Read the kismet documents as Thorn stated.
    It has the exact answer to your question.
    Might also wanna have a look into basic linux as well.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  4. #4
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    6

    Default Kismet not properly configuring the loopback network interface

    root@bt:/usr/etc# kismet_server
    ERROR: Kismet was started as root, NOT launching external control binary. This
    is NOT the preferred method of starting Kismet as Kismet will continue
    to run as root the entire time. Please read the README file section
    about Installation & Security and be sure this is what you want to do.
    INFO: Reading from config file /usr/etc/kismet.conf
    INFO: No 'dronelisten' config line and no command line drone-listen argument
    given, Kismet drone server will not be enabled.
    INFO: Created alert tracker...
    ERROR: Failed to open primary plugin directory (/usr/lib/kismet/): No such file
    or directory
    ERROR: Failed to open user plugin directory (/root/.kismet//plugins/): No such
    file or directory
    INFO: Kismet will attempt to hop channels at 5 channels per second unless
    overridden by source-specific options
    INFO: No specific sources named on the command line, sources will be read from
    kismet.conf
    INFO: Using default channel list 'IEEE80211b' on source 'wifi0'
    INFO: Created source wifi0 with UUID 825ae5e2-6902-11de-9c8c-c0041120df01
    INFO: Will attempt to reopen on source 'wifi0' if there are errors
    ERROR: TCP server bind() failed: Address already in use
    FATAL: Failed to enable TCP listener for the Kismet UI server
    INFO: Shutting down plugins...

    *** KISMET IS FLUSHING BUFFERS AND SHUTTING DOWN ***

    *** KISMET HAS ENCOUNTERED A FATAL ERROR AND CANNOT CONTINUE. ***
    Shutting down log files...
    FATAL: Failed to enable TCP listener for the Kismet UI server
    Kismet exiting.
    --------------------------------------------------------------------
    Changing this line helped at least to get some output:
    # Client/server listen config
    #listen=tcp://127.0.0.1:2501
    listen=tcp://0.0.0.0:2501

    -------------------------------------------------------------------------
    Also having trouble with the "ncsource" using ath5k in place of
    madwifi_g and wlan0 in place of wifi0.
    ----------------------------------------------------------------------
    Putting card in monitor mode:
    root@bt:/usr/etc# airmon-ng

    Interface Chipset Driver
    wlan0 Atheros ath5k - [phy0]
    root@bt:/usr/etc# airmon-ng start wlan0
    Interface Chipset Driver
    wlan0 Atheros ath5k - [phy0]
    (monitor mode enabled on mon0)
    -----------------------------------------------------------------------
    Packet injection works:
    #aireplay-ng -9 mon0 -i mon1
    .............Injection is working...
    .............Trying card-to-card injection ...OK

  5. #5
    Member
    Join Date
    Jan 2010
    Posts
    81

    Default

    @xilni

    usr/etc/kismet.conf

    change the ncsource line to:
    ncsource=wlan0:name=intel


    good luck...

    ozzy

  6. #6
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    6

    Default

    It seems that "ncsource=wlan0" is all I need. That part looks OK for now.
    -------------------------------------------------------------------------
    My problem is with the TCP listener for the Kismet UI server. This seems like a Kismet problem:
    the output:
    root@bt:/usr/etc# kismet_server
    ERROR: Kismet was started as root, NOT launching external control binary. This
    is NOT the preferred method of starting Kismet as Kismet will continue
    to run as root the entire time. Please read the README file section
    about Installation & Security and be sure this is what you want to do.
    INFO: Reading from config file /usr/etc/kismet.conf
    INFO: No 'dronelisten' config line and no command line drone-listen argument
    given, Kismet drone server will not be enabled.
    INFO: Created alert tracker...
    ERROR: Failed to open primary plugin directory (/usr/lib/kismet/): No such file
    or directory
    ERROR: Failed to open user plugin directory (/root/.kismet//plugins/): No such
    file or directory
    INFO: Kismet will attempt to hop channels at 5 channels per second unless
    overridden by source-specific options
    INFO: No specific sources named on the command line, sources will be read from
    kismet.conf
    INFO: Matched source type 'ath5k' for auto-type source 'wlan0'
    INFO: Using default channel list 'IEEE80211b' on source 'wlan0'
    INFO: Created source wlan0 with UUID 8a626fd4-69ad-11de-a2e4-bf034515e201

    INFO: Will attempt to reopen on source 'wlan0' if there are errors
    ERROR: TCP server bind() failed: Address already in use
    FATAL: Failed to enable TCP listener for the Kismet UI server
    INFO: Shutting down plugins...

    *** KISMET IS FLUSHING BUFFERS AND SHUTTING DOWN ***

    *** KISMET HAS ENCOUNTERED A FATAL ERROR AND CANNOT CONTINUE. ***
    Shutting down log files...
    FATAL: Failed to enable TCP listener for the Kismet UI server
    Kismet exiting.

  7. #7
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by from_beyond View Post
    My problem is with the TCP listener for the Kismet UI server. This seems like a Kismet problem:
    Again it is not a kismet problem but your lack of reading the documentation and as well as the error messages that are given.
    An INFO message is not an error. It is as stated, information for you.
    The error starts with the following:

    Code:
    ERROR: Kismet was started as root, NOT launching external control binary.  This is NOT the preferred method of starting Kismet as Kismet will continue  to run as root the entire time.  Please read the README file section
    about Installation & Security and be sure this is what you want to do.
    Then this:
    Code:
     ERROR: Failed to open primary plugin directory (/usr/lib/kismet/): No such file or directory ERROR: Failed to open user plugin directory (/root/.kismet//plugins/): No such  file or directory
    Which also leads to the below:
    Code:
    ERROR: TCP server bind() failed: Address already in use
    FATAL: Failed to enable TCP listener for the Kismet UI server
    FATAL: Failed to enable TCP listener for the Kismet UI server
    Kismet exiting.
    
    What you highlighted in blue is nothing more than information for you to enjoy, it does not mean that the program will not work, but rather it may not work at the optimum.
    Again have a look at the documentation linked above.
    It will tell you how to setup the configuration file.
    Take a look and see if the two missing directories are located where the error messages say they should be. If they are there then there is a reason they are not being accessed. If the are not there then one needs to find where they are and either move them or sym link them.


    Let us know what you find out.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  8. #8
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    6

    Default Kismet seems to be working now but still more to be done

    After putting my card in promiscuous I put a desktop icon of Kismet on my Desktop. I set permissions to executable.
    I then edited kismet.conf and added the following:
    for my card "ncsource=wlan0
    ---------------------------------------------------------------
    I then addedin red two lines from a 2005 version to this 2009 kismet.conf)
    # Client/server listen config
    listen=tcp://127.0.0.1:2501
    # People allowed to connect, comma seperated IP addresses or network/mask
    # blocks. Netmasks can be expressed as dotted quad (/255.255.255.0) or as
    # numbers (/24)
    allowedhosts=127.0.0.1
    # Maximum number of concurrent GUI's
    maxclients=5
    # Maximum backlog before we start throwing out or killing clients. The
    # bigger this number, the more memory and the more power it will use.
    maxbacklog=5000
    # Port to serve GUI data
    tcpport=2501
    # this host, reverts to INADDR_ANY if specified incorrectly.
    bindaddress-127.0.0.1

    --------------------------------------------------------------------
    I then started the kismet_server in a terminal and launched kismet from the icon. All this seemed to get it going.
    -----------------------------------------------------------------------
    archangel---Thanks for your input. I spotted a different problem. What you mentioned may not be the problem.
    The README did not help and I am running BT4 live so being on root should not matter.
    Kismet should not have the issues mentioned below--it never did on previous versions.
    Looks a bit buggy to me.

  9. #9
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    6

    Default Backtrack4 pre-final Kismet broken

    Yes! Kismet is broken in this pre-final version but there seems to be a fix for it. I need 11 posts to submit the URL that has the fix. I wish both Ubuntu 9.04 and BT4 would get it right on Kismet. I hope the final version of BT4 does.

  10. #10
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by from_beyond View Post
    Yes! Kismet is broken in this pre-final version but there seems to be a fix for it. I need 11 posts to submit the URL that has the fix. I wish both Ubuntu 9.04 and BT4 would get it right on Kismet. I hope the final version of BT4 does.
    For submitting links use hxxp instead of http w w w etc.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •