Results 1 to 8 of 8

Thread: How to configura WPA Supplicant with RTL8187 USB CARD

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    2

    Question How to configura WPA Supplicant with RTL8187 USB CARD

    Hi
    How to configure wpa_supplicant with rtl8187 usb 2.0 wireless card in Back Track?
    If I open the wpa_supplicant GUI search the driver for the network card.
    Thanks
    Spigolo

  2. #2
    Good friend of the forums
    Join Date
    Feb 2009
    Posts
    356

    Default

    configure it through the command line and start it through the command line. the gui is not functional in bt3. And in bt4... there is network manager

  3. #3
    Member kazalku's Avatar
    Join Date
    Feb 2009
    Posts
    416

    Default

    Quote Originally Posted by spigolo View Post
    Hi
    How to configure wpa_supplicant with rtl8187 usb 2.0 wireless card in Back Track?
    If I open the wpa_supplicant GUI search the driver for the network card.
    Thanks
    Spigolo
    Are you after these commands, if so then try it.........
    **password** means enter your AP password here (without **)
    same with **put essid**

    Code:
    ifconfig rausb0 down
    macchanger -m 00:11:22:33:44:55 rausb0
    ifconfig rausb0 up 
    iwconfig rausb0 mode managed
    iwconfig rausb0 essid **put essid**
    iwpriv rausb0 set AuthMode=WPAPSK
    iwpriv rausb0 set WPAPSK=**password**
    iwpriv rausb0 set EncrypType=TKIP
    dhcpcd rausb0

  4. #4
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    2

    Default

    Ok Perfetct
    Thanks

  5. #5
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    16

    Default

    Did that work for you Im having A lot of trouble connecting to my WPA router with my dlink DWA-110 and my 4965agn, both work under aircrack perfectly, but i cant connect to wpa networks, if i use wlassitant i get FAILED connection constantly, and a wpa error in shell.

    Loaded application options.
    All interfaces: eth0, pan0, wlan0, wlan1, wmaster0, wmaster1
    Wireless interface(s): wlan0, wlan1
    Permissions checked.
    DHCP Client: dhclient
    All executables found.
    scan: /sbin/iwlist wlan0 scan
    Networks found: 2
    Selected interface: wlan1
    scan: /sbin/iwlist wlan1 scan
    Networks found: 2
    ACTION: CONNECT.
    No DHCP client running.
    No pre-connection command specified.
    iwconfig_set: /sbin/iwconfig wlan1 mode managed channel 6 key off essid Araque
    iwconfig_ap: /sbin/iwconfig wlan1 ap 00:18:39:6F39
    ==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
    Using wpa_supplicant driver: wext
    WPA client started. Waiting for status...
    ==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
    CONNECTION FAILED.
    disconnect: /sbin/iwconfig wlan1 mode managed key off ap off essid off

  6. #6

    Default

    I could be mistaken, but I'm under the impression that if you want to connect to a WPA network using the rt8187 drivers in BT3, you need to use the ndiswrapper driver. This problem is fixed in BT4.

  7. #7
    Just burned his ISO
    Join Date
    Jul 2006
    Posts
    15

    Default

    rt8187 + wpa_supplicant = not work (BT3).
    I tried the ndiswrapper driver, it does not work either.
    I'm also an rt8187 owner and I've seen this question coming several times.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •