Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: injection/association question???

  1. #1
    Junior Member
    Join Date
    Dec 2008
    Posts
    72

    Question injection/association question???

    I was trying to show a friend how easy it was to crack his wep network. WITH HIS CONSENT I attempted to crack his key. I had good power around 87, and beacons was moving good, but I couldn't associate with aireplay-ng -1 0 -a (bssid) -h (my mac) wlan0. This is strange because he has the same type of router I have, and I've cracked my owns twice. I checks injection with aireplay-ng -9 wlan0 it scans, and finds 2 essids. It then tests injection on both, but its only working for the network that isn't his. Why is that?

    Also I've read in the forum to fix this use airodump-ng wlan0. Then airodump-ng -c wlan0. I guess their saying specifying the channel corrects the issue, but IF that was true that couldn't apply to me because both essids is on the same channel.

    My adapter: Linksys wusb54gc

  2. #2
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Default

    there may be numerous reasons.
    MAC Filtering is on
    there may be some diff. technically according to rev. number in both the AP's.thus sometime aireplay fails against some of AP's
    go a little far from AP & check that same freq. spectrum & interference not being created by Microwave owen
    try with iwconfig rausb0/mon0 rate 1M
    check you are getting SSID in airodump or it may show length:1 or length:7 according to hidden SSID length

  3. #3
    Member kazalku's Avatar
    Join Date
    Feb 2009
    Posts
    416

    Default

    First, I'm assuming that you've set your card to monitor mode and to the desired channel with airmon-ng prior to running any of the tests. Could you please check these again? Are both AP using same channel? And finally, you are pretty sure that the card is on the same channel as your AP, don't you?

    Again, not all APs respond to broadcast probe requests. Have a read:
    http://www.aircrack-ng.org/doku.php?..._don_t_respond

  4. #4
    Junior Member
    Join Date
    Dec 2008
    Posts
    72

    Default

    Thanks for the reply.Yes their both on the same channel, and yes I've specified the channel, and made sure it was in monitor mode, but the same thing happened because their on the same channel. Also does distance have any thing to do with it because sometimes I'll test injection, and it will (I guess) show injection at a nice rate then when the link is low it shows it at a slow rate. Could this also be a reason?

  5. #5
    Junior Member
    Join Date
    Dec 2008
    Posts
    72

    Default

    Ok I think found the problem. I moved a little closer and injection worked partially (not that strong), but I still showed him how unsafe wep is. I cracked it!! Thanks for your help.

  6. #6
    Member kazalku's Avatar
    Join Date
    Feb 2009
    Posts
    416

    Default

    Quote Originally Posted by kid protocol View Post
    Ok I think found the problem. I moved a little closer and injection worked partially (not that strong), but I still showed him how unsafe wep is. I cracked it!! Thanks for your help.
    Could you please post these for future reference:
    1) Signal strength @ injection was not working at all: .......??
    2) Signal strength @ injection started working: .......??
    3) Signal strength @ injection worked perfectly: .......??
    Thank you

  7. #7
    Junior Member
    Join Date
    Dec 2008
    Posts
    72

    Default

    Quote Originally Posted by kazalku View Post
    Could you please post these for future reference:
    1) Signal strength @ injection was not working at all: .......??
    2) Signal strength @ injection started working: .......??
    3) Signal strength @ injection worked perfectly: .......??
    Thank you
    I don't quite understand what you are saying. What exactly are you looking for?

  8. #8
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    21

    Default

    Quote Originally Posted by kid protocol View Post
    I don't quite understand what you are saying. What exactly are you looking for?
    I think he wants to know the signal strength at which injection worked and did not work.

  9. #9
    Member kazalku's Avatar
    Join Date
    Feb 2009
    Posts
    416

    Default

    Quote Originally Posted by Abbygail View Post
    I think he wants to know the signal strength at which injection worked and did not work.
    Definitely... sorry for the confusion

  10. #10
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by kazalku View Post
    Could you please post these for future reference:
    1) Signal strength @ injection was not working at all: .......??
    2) Signal strength @ injection started working: .......??
    3) Signal strength @ injection worked perfectly: .......??
    Thank you
    This information will be completely useless for anyone else than the OP. First of all the signal strength readings given by airodump-ng is not comparable between different drivers and/or wireless cards. Secondly it only measures the quality of the signal originating from the AP, and not the other way around. This means that when working with a weak wireless card and strong target AP it is quite possible that the target is unable to pick up the packets injected by you, even though the PWR reading indicates a strong signal.

    To put it in another way, there are too many variables involved for this information to be of any real use for anyone else.
    -Monkeys are like nature's humans.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •