Results 1 to 3 of 3

Thread: 0trace

  1. #1
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    1

    Default 0trace

    I'm using vmware image of BT4 beta. 0trace failed to start with this message:

    root@bt:~# 0trace.sh eth0 xxx.xxx.xxx.xxx
    [-] /bin/usleep not found on this system, sorry.

    Looks like ubuntu doesn't have usleep installed by default.

    Quick fix: compile this C file as usleep and put in your /bin folder

    usleep.c

    #include <stdio.h>
    #include <stdlib.h>
    #include <unistd.h>

    int main (int argc, char **argv) {
    usleep(atoi(argv[1]));
    return 0;
    }

  2. #2
    Just burned his ISO
    Join Date
    Aug 2007
    Posts
    2

    Default

    worked for me. thanks.

    -jcran

  3. #3
    Just burned his ISO dukocuk's Avatar
    Join Date
    Sep 2006
    Posts
    4

    Default

    standing inside /bin i did:

    vi usleep.c and typed in what you wrote as sourcecode.

    then gcc usleep.c, it seems like i accepted it.

    but still i get the same error?!?

    Okey sry guys , it works now!

    i forgot to do this

    $ gcc -o usleep usleep.c


    "If your file is named usleep.c then type '-o usleep' as the parameter to gcc. This is basically your suggested name for the executable file that gcc would create. In case you typed something like the following"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •