Hey,

There are lots of compatibility problems with these cards as there are sooo many variations.

Here's how to get it working First lets find out what variation of card you have.

Code:
aplay -l
My output is as follows ..

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: INTEL HDMI [INTEL HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Ok now you can see what variation of card you have lets set it up ..

See the following link for the configurations available .

Either take a look at ..

/usr/src/linux-*/Documentation/sound/alsa/HD-Audio-Models.txt

Or use the link below

Linux Kernel Documentation :: sound : alsa : HD-Audio-Models.txt

Find the available configurations for your card. For example Mine is STAC92xx so I look for my card.

Once you have found your card, lets add the model to alsa's configuration file.

cd over to /etc/modprobe.d and check the directory for the alsa configuration file. I've seen several variations for eg "alsa-base.conf, sound.conf,sound".

Once you've found your config file you can add the model option .

for eg ...

Code:
options snd-hda-intel model=YOUR_MODEL
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
and reboot.

Still no sound ?? Try another configuration I know this cam be a pain in the bum but if you want sound keep going.

More info here ...

https://help.ubuntu.com/community/HdaIntelSoundHowto

Hope this helps.