Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Intel WiFi Link 5100

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    9

    Default Intel WiFi Link 5100

    Works well out of the box in BT4. Not detected by Network Manager though, so I'm just using the terminal to connect it to my network.

    Here's how I'm doing it (numbers with stars prefixing is for WPA/WPA2 only):

    *1. Create a conf file in /etc called wpa_supplicant.conf

    *2. Put the following in the conf file (making adjustments as necessary):
    Code:
    #
    ctrl_interface=/var/run/wpa_supplicant
    
    eapol_version=1
    
    ap_scan=1
    
    fast_reauth=1
    
    network={
    ssid="YOUR SSID GOES HERE"
    psk="YOUR WPA PASSWORD GOES HERE"
    priority=5
    }
    #
    3. Bring the interface up - 'ifconfig wlan0 up'

    4. Scan for open access points (ensures the card is functioning) - 'iwlist wlan0 scan'

    5. Associate with AP - 'iwconfig wlan0 essid myssid' (replace myssid with your AP)

    6. Set the password for the AP (if there is one)
    If you have no encryption: Skip this step.
    If you have WEP encryption: 'iwconfig wlan0 key mykey' (replace mykey with your WEP key in hex)
    If you have WPA encryption: 'wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -B'

    7. Obtain an IP address: 'dhclient'

    You should be done. Network Manager won't recognize the connection but everything else seems to work fine.

  2. #2
    Junior Member
    Join Date
    Jan 2010
    Posts
    42

    Default try this

    If you run
    Code:
    /etc/init.d/NetworkManager start
    in a terminal then Network Manager will see everything. Network Manager (or networking) is turned off by default.

  3. #3
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    3

    Default

    Duh..... once you start the network manager it works....BT4 so far so good...thanks much PunkRockk

  4. #4
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    9

    Default

    Quote Originally Posted by punkrokk View Post
    If you run
    Code:
    /etc/init.d/NetworkManager start
    in a terminal then Network Manager will see everything. Network Manager (or networking) is turned off by default.
    Oh, I've always just done all of my network setup in any distro by hand.

    Never really used Network Manager, didn't know it was disabled from the get go.


  5. #5
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    2

    Default

    I have the Intel wireless Wifi Links 5100 too but backtrack4 can't detect it, do i have to install some drivers? the ethernet already works but wirless...

  6. #6
    Just burned his ISO
    Join Date
    Dec 2008
    Posts
    3

    Default

    You have to do "ifconfig wlan0 up" to set the wireless card up.
    Then it works.

    But does anyone know how to get injection working with this card ??

    Greetz

  7. #7
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    3

    Default

    Is the Intel 5300 AGN driver the same as the 5100? If not where could I get the driver for my card.

  8. #8
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    9

    Default

    Quote Originally Posted by Greval View Post
    You have to do "ifconfig wlan0 up" to set the wireless card up.
    Then it works.

    But does anyone know how to get injection working with this card ??

    Greetz
    Honestly, I haven't tried injection yet, that's the only thing I haven't tried, mind you.

    Not sure what you can do, I don't think any of the 49** and on series support injection yet.

  9. #9
    Junior Member
    Join Date
    Apr 2010
    Posts
    37

    Default

    Thank you got_milk?
    Works great ;]

  10. #10
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    11

    Default Intell 5300 not working

    EDIT: I got it working. Seems to be doing fine but fakeauth is not working.



    Whatever I've tried I can not get this wireless card to work (intel 5300)

    To give a little details:
    when I try iwscan list - it tells me

    wmaster0 Interface doesn't support scanning.

    wlan0 Interface doesn't support scanning : Device or resource busy.

    I have no idea what is wrong, I have install latest drivers and everything.

    Another thing that I do not see working well is that when I run

    lshw -C network

    I get

    description: Wireless interface
    product: PRO/Wireless 5300 AGN [Shiloh] Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:08:00.0
    logical name: wmaster0
    version: 00

    Isn't this supposed to be wlan0 ?

    Maybe someone has some idea.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •