Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: apt-get update GPG error: http://ppa.launchpad.net intrepid Release

  1. #11
    Junior Member
    Join Date
    Dec 2007
    Posts
    63

    Default

    I did this and it failed

    sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com CB2F6C86F77B1CA9

    gpg: requesting key F77B1CA9 from htp server keyserver.ubuntu.com
    gpg: keyserver timed out
    gpg: keyserver receive failed: keyserver error

    Any help much appreciated

  2. #12
    Just burned his ISO
    Join Date
    May 2009
    Posts
    15

    Default

    Double check that your network is active, do a ping on something that you know will work, like
    ping google.com

  3. #13
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by Tiptoe View Post
    I did this and it failed
    sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com CB2F6C86F77B1CA9
    EDIT: see below. In the meantime try the following.
    Just try to do:
    Code:
    gpg --keyserver keyserver.ubuntu.com --recv CB2F6C86F77B1CA9
    gpg --export --armor CB2F6C86F77B1CA9 | apt-key add -
    Quote Originally Posted by leftler View Post
    Double check that your network is active, do a ping on something that you know will work, like
    Much better than before.
    Might want to add a -c option for the number of packets to send as well.


    Mods apologies for the double post. Please merge.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  4. #14
    Just burned his ISO
    Join Date
    May 2009
    Posts
    15

    Default

    Quote Originally Posted by archangel.amael View Post
    I don't believe the adv command above will not work with the present version of bt.
    It does work with the current VM-ware version, I just did it myself yesterday.

  5. #15
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by leftler View Post
    It does work with the current VM-ware version, I just did it myself yesterday.
    You are correct, my apologies.
    I just tried the command above and it worked just fine.
    I also tried the other way as mentioned above and they worked too.

    So it looks like it is not with the key server but rather the OP's network connection itself.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  6. #16
    Junior Member
    Join Date
    Dec 2007
    Posts
    63

    Default

    Great many thanks it worked!

    Took usb key home and worked without the --adv option!


  7. #17
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    18

    Default

    Hmm...

    This solution:

    gpg --keyserver keyserver.ubuntu.com --recv CB2F6C86F77B1CA9
    gpg --export --armor CB2F6C86F77B1CA9 | apt-key add -

    with minor modifications because I use a proxy server:

    gpg --keyserver-option proxy-server=x.x.x.x:8080 keyserver.ubuntu.com --recv CB2F6C86F77B1CA9
    gpg --export --armor CB2F6C86F77B1CA9 | apt-key add -

    do not work for me:

    - the error message that I receive is:

    "
    gpg: requesting key F77B1CA9 from hkp server keyserver.ubuntu.com
    gpgkeys: key CB2F6C86F77B1CA9 not found on keyserver
    gpg: no valid OpenPGP data found.
    gpg: Total number processed: 0
    "

    Any ideas ?

    Thank you and regards.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •