Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 50

Thread: Bt4 dual boot tutorial

  1. #21
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default

    You said when you boot from the USB stick your harddrive is assigned sdb instead of sda? If you boot from a LiveCD it is sda?
    Tiocfaidh ár lá

  2. #22
    Junior Member
    Join Date
    Nov 2008
    Posts
    32

    Default

    Unfortunately I have no disc drive, just USB.

    I did think this could be part of the issue, so did try editing lilo.conf (with sdb as the HDD), then starting lilo, then editing lilo.conf back to sda in anticipation of booting, but that did not work either.

  3. #23
    Member
    Join Date
    Feb 2010
    Location
    Root
    Posts
    121

    Default

    Thanks. I will check tonight after class, I wil try with nano. Will post my results. I will check into making sure I have the correct partition numbers as well.

  4. #24
    Member
    Join Date
    Feb 2010
    Location
    Root
    Posts
    121

    Default

    OKay, it seems as though I had root pointed at "hda", not "sda"

    Thanks for the help again, I feel like a noob

  5. #25
    Junior Member
    Join Date
    Nov 2008
    Posts
    32

    Default

    Ok, I'm still in the weeds. When I boot with the BT4 USB, my HDD becomes /dev/sdb, so I think that's causing problems with LILO
    1) I edit lilo.conf to sdb so that it works when I load it 'lilo -v'...but when I reboot, it's now sda, so that didn't work (panic)
    2) I edit lilo.conf to sdb, load lilo, then edit conf back to sda...doesn't work, same kernel panic
    3) I install nUbuntu via the Ubuntu installer, (w/GRUB)...all is well. So I tried just taking the existing partition structure and installing the various BT folders/files...ended up getting GRUB error 17...tried editing default.cap to no avail.
    4) Tried sticking with the install guide, inserting some GRUB language:
    Code:
    # mke2fs /dev/sdb1
         # mount -t ext2 /dev/sdb1 /mnt
         # grub-install --root-directory=/mnt /dev/sdb1
         # umount /mnt
    (for full disclosure, my vista partition is /sdb2, so my boot partition is 1, swap is 3, rest is 4, but I've tried so many alternatives (extended partitions, no swap) that I think the issue is with the boot loader. This time I got GRUB error 22.

    Last comment: I do have a nUbuntu USB, and when used, the usb is sdb, HDD is sda...is there a way to edit SOMETHING on the BT usb to direct this assignment? I did try reordering my boot order in BIOS but nothing changed.

    Also, no CD drive available so when I get to the point where I really need to get to vista, I just boot to nUbuntu, clear partitions with fdisk, then go back to the installer...grub sees vista just fine and I'm in business...but I want to be in business w/BT4, not nUbuntu.

  6. #26
    Just burned his ISO
    Join Date
    Feb 2008
    Posts
    3

    Default Kernel Panic No init Found?

    Never mind! The answer was in my lilo.conf file. I didn't change the "root=" reference. All is working well now.

    dubZ3r0 <-- suffers from ID10t syndrome...



    Hey all,
    I followed the tut to the "T" making the necessary changes for my volumes and everything went just as expected. That is until I rebooted and selected the BT4 option in LILO. At that point I get a panic message that reads "Kernel panic - not syncing: No init found. Try passing init= option to kernel." I searched online but there seems to be a number of issues that can result in this behavior. I'm hoping this group can narrow down the issue resulting from the steps within this tut.

    I'm attempting to dual boot an ASUS eeepc 1000dh btw.

    Thanks.

  7. #27
    Junior Member digitalfriction's Avatar
    Join Date
    Mar 2010
    Posts
    84

    Default

    Hi, could do with some help, I have so far been running BT4B from DVD and USB, but I have decided to follow the tutorial and do a dual boot, I am dual booting with Windows 7 Beta.

    I have followed the instructions as written, and received no errors.

    On reboot I have 2 problems:

    1) The lilo screen does not appear properly, just a few lines at the top of the screen, almost like the graphics is set wrong. I think this may be to do with the Toshiba Bios Splash Screen on the laptop I am using, so this is not as important as problem 2

    2) I get the 'Kernel panic - not syncing: No init found. Try passing init= option to kernel.' error. I have tried to resolve this by doing the following:

    a) Booted from the Live DVD, then opened a shell, cd /mnt/sda4, nano lilo.conf, I have then tried removing the 'initrd=/boot/splash.initrd' line as suggested in another post on these forums.

    b) I have also checked that I have my root and boot lines correct, I have boot set as /dev/sda and root set as /dev/sda4

    c) I have searched on google, and using the search on the forum, I have found a few posts, all of which suggest the things I have tried, or do not reach an answer, most of the results from google do not seem specific enough for BT4B

    I apologise if I have not searched well enough, but I have tried, and could do with some help please.


    Update: I have tried changing the root= line I have set it to /dev/sda4 and /dev/sda3 and /dev/sda2. All have the same result.

    I have also looked at the directory structure that was created during the install, and strangely enough /mnt/sda4/boot is empty, so I have copied the contents of the boot folder from the liveDVD to /mnt/sda4/boot, but this has also made no difference.

    I am going to try again from scratch, and if it doesnt work I will try without windows being installed.

    Could still do with some help, I know everyones busy, but if you can !! Thanks

  8. #28
    Junior Member digitalfriction's Avatar
    Join Date
    Mar 2010
    Posts
    84

    Default

    Sorry to repost, last post is looking a bit long now.

    I have now also tried to run the installer posted on another thread here (unofficial installer) this still has the same problem.

    I dont think there is anything else I can do other than try fresh install, without windows, but if anyone can help please do.

  9. #29
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    post you entire lilo.conf

  10. #30
    Junior Member digitalfriction's Avatar
    Join Date
    Mar 2010
    Posts
    84

    Default

    lba32
    boot = /dev/sda
    root = /dev/sda4
    # bitmap=/boot/sarge.bmp
    # bmp-colors=1,,0,2,,0
    # bmp-table=120p,173p,1,15,17
    # bmp-timer=254p,432p,1,0,0
    # install=bmp
    # delay=20
    prompt
    timeout=50
    # map=/boot/map
    vga=0x317
    image=/boot/vmlinuz
    label=BT4
    read-only
    initrd=/boot/splash.initrd
    append=quiet

    other=/dev/sda1
    label=Windows7
    table=/dev/sda


    Here is fdisk readout:

    root@bt:/mnt/sda4/etc# fdisk /dev/sda

    The number of cylinders for this disk is set to 14593.
    There is nothing wrong with that, but this is larger than 1024,
    and could in certain setups cause problems with:
    1) software that runs at boot time (e.g., old versions of LILO)
    2) booting and partitioning software from other OSs
    (e.g., DOS FDISK, OS/2 FDISK)

    Command (m for help): p

    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x01b62676

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 7297 58608128 7 HPFS/NTFS
    /dev/sda2 * 7297 7305 68260+ 83 Linux
    /dev/sda3 7306 7567 2104515 82 Linux swap / Solaris
    /dev/sda4 7568 14593 56436345 83 Linux


    and fstab:

    /dev/sda4 / reiserfs defaults 0 0 # AutoUpdate
    proc /proc proc defaults 0 0 # AutoUpdate
    sysfs /sys sysfs defaults 0 0 # AutoUpdate
    devpts /dev/pts devpts gid=5,mode=620 0 0 # AutoUpdate
    tmpfs /dev/shm tmpfs defaults 0 0 # AutoUpdate

Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •