Results 1 to 3 of 3

Thread: Booting USB Flash Drive with GRUB Installed on Internal Hard Drive

  1. #1
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    4

    Default Booting USB Flash Drive with GRUB Installed on Internal Hard Drive

    I am attempting to boot BT3 from USB on a laptop that does not support booting from USB in BIOS. I do not want to burn a CD as I do not have any readily available. My current setup is a dual-boot to Ubuntu and Windows XP via GRUB on my internal hard drive. I installed BT3 on a 1GB USB flash drive. I am trying to boot the USB flash drive using the internally installed GRUB. I copied the vmlinuz and initrd files from boot on the flash drive to /boot on my Ubuntu install. I then added the following to my /boot/grub/menu.lst
    Code:
    title  	        USB Drive
    root		(hd0,4)
    kernel	/vmlinuz-usb vga=791 root=UUID=88d0-1b2b ro
    initrd		/initrd-usb
    quiet
    When I restart and select this option in GRUB, it begins to load BT3 but fails. First it failed at the end of linuxrc in the initrd when it attempts to run init saying, init usage [012345... (or something along those lines).
    If I edit the linuxrc file within the initrd (which I don't think is the correct way to solve the problem) to include in the call to init a runlevel of 2, I get a different error message saying, init: file not found: /dev/initctl

    Thank you for assistance.

  2. #2
    Good friend of the forums
    Join Date
    Jan 2010
    Location
    outside chicago, il
    Posts
    442

    Default

    Quote Originally Posted by jgrocho View Post
    I am attempting to boot BT3 from USB on a laptop that does not support booting from USB in BIOS. I do not want to burn a CD as I do not have any readily available. My current setup is a dual-boot to Ubuntu and Windows XP via GRUB on my internal hard drive. I installed BT3 on a 1GB USB flash drive. I am trying to boot the USB flash drive using the internally installed GRUB. I copied the vmlinuz and initrd files from boot on the flash drive to /boot on my Ubuntu install. I then added the following to my /boot/grub/menu.lst
    Code:
    title  	        USB Drive
    root		(hd0,4)
    kernel	/vmlinuz-usb vga=791 root=UUID=88d0-1b2b ro
    initrd		/initrd-usb
    quiet
    When I restart and select this option in GRUB, it begins to load BT3 but fails. First it failed at the end of linuxrc in the initrd when it attempts to run init saying, init usage [012345... (or something along those lines).
    If I edit the linuxrc file within the initrd (which I don't think is the correct way to solve the problem) to include in the call to init a runlevel of 2, I get a different error message saying, init: file not found: /dev/initctl

    Thank you for assistance.
    BT does not support root=UUID try using root=/dev/sdXX instead (replace XX with the the correct drive letter and partition number. Also you have to add rootdelay=12 to force the boot process to wait until the usb driver finishes scanning the bus for your drive.
    I like the bleeding edge, but I don't like blood loss

  3. #3
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    4

    Default

    Quote Originally Posted by bofh28 View Post
    BT does not support root=UUID try using root=/dev/sdXX instead (replace XX with the the correct drive letter and partition number. Also you have to add rootdelay=12 to force the boot process to wait until the usb driver finishes scanning the bus for your drive.
    Thank you for your quick response. However, I am still getting an error saying: "Usage: init 0123456SsQqAaBbCcUu" after changing to root=/dev/sda1 (during boot it says "Using BT3 data from /mnt/sda1/BT3) and adding rootdelay=12.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •