Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: How to setup WPA connection?

  1. #11
    peithan
    Guest

    Default

    Quote Originally Posted by cybrsnpr View Post
    Try this:

    cat "options ath_pci countrycode=752" > /etc/modprobe.d/madwifi
    madwifi-unload
    modprobe ath_pci

    Then run: iwlist ath0 freq
    and see if channel 13 is now available
    Removed from /etc/modprobe.conf and added to ../modprobe.d/madwifi

    Nothing happens, the countrycode just wont change.
    also tried to:
    madwifi-unload
    modprobe ath_pci countrycode=752
    and i got:
    dev.ath.countrycode = 752
    but i couldnt use the device, so i had to unload madwifi driver again and run modprobe ath_pci then the device showed up again.
    but it also showed :
    dev.ath.countrycode = 0

    What can i do? Why is this?
    It's like it completely ignores the countrycode what so ever. And i am crawling out of my skin soon :@

  2. #12

    Default

    This may not be a driver issue. I have 2 different pcmcia cards that use the same madwifi-ng drivers (orinoco and a ubiquiti). On the orinoco, all I need to do is to change the freq setting, nothing else required. On the ubiquiti, I have to go through the process I previously described. I've also tried other cards using the same drivers and couldn't get them to use these channels. My guess is that this is a firmware issue and that your card will not accept freq changes issued by software.

    Not that I have a fix, but what make/model of card are you using?

    I would suggest that you get on your google horse and see if anyone else has used your specific card successfully on these channels and how they did it. Or, go to the manufacturers web site and see if they have a fix for this problem.

  3. #13
    peithan
    Guest

    Default

    Quote Originally Posted by cybrsnpr View Post
    This may not be a driver issue. I have 2 different pcmcia cards that use the same madwifi-ng drivers (orinoco and a ubiquiti). On the orinoco, all I need to do is to change the freq setting, nothing else required. On the ubiquiti, I have to go through the process I previously described. I've also tried other cards using the same drivers and couldn't get them to use these channels. My guess is that this is a firmware issue and that your card will not accept freq changes issued by software.

    Not that I have a fix, but what make/model of card are you using?

    I would suggest that you get on your google horse and see if anyone else has used your specific card successfully on these channels and how they did it. Or, go to the manufacturers web site and see if they have a fix for this problem.
    I am using this internal card in my Asus Aspire laptop:
    Atheros Communications Inc. AR5006EG.

    I will try google some and see what i can find. I will try get my other card to work. My Alfa adapter: AWUS036H. Cant really seem to get this to work either. But this one can be set to channel 13, but it wont connect to my ap using wpa_supplicant. I think the drivers may be wrong.

    Since i am getting tons of Operation not permitted and other error msgs. Will try to post log here of what i am doing and what errors im getting.

  4. #14
    peithan
    Guest

    Default

    Connected through cable on my bt3 laptop now.

    Trying to get this other device (ALFA) to work with wpa.

    bt ~ # cat /etc/wpa_supplicant.conf

    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    ap_scan=1

    network={
    ssid="B2_Private_52"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group=CCMP TKIP
    psk="5014477j61292"
    }
    bt ~ #
    bt ~ # iwconfig wlan0 mode managed
    bt ~ #
    bt ~ # wpa_supplicant -w Dwext -iwlan0 -c /etc/wpa_supplicant.conf
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 5 value 0x1 - ctrl_iface exists and seems to be in use - cannot override it
    Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
    Failed to initialize control interface '/var/run/wpa_supplicant'.
    You may have another wpa_supplicant process already running or the file was
    left by an unclean termination of wpa_supplicant in which case you will need
    to manually remove this file before starting wpa_supplicant again.

    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 5 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 4 value 0x0 - bt ~ #

    from dmesg:

    wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
    wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
    wifi0: H/W encryption support: WEP AES AES_CCM TKIP
    wifi0: Atheros AR2425 chip found (MAC 14.2, PHY SChip 7.0, Radio 10.2)
    wifi0: Use hw queue 1 for WME_AC_BE traffic
    wifi0: Use hw queue 0 for WME_AC_BK traffic
    wifi0: Use hw queue 2 for WME_AC_VI traffic
    wifi0: Use hw queue 3 for WME_AC_VO traffic
    wifi0: Use hw queue 4 for XR traffic
    wifi0: Use hw queue 7 for UAPSD traffic
    wifi0: Use hw queue 8 for CAB traffic
    wifi0: Use hw queue 9 for beacons
    wifi0: ath_announce: Driver has Karma 1.1 patches by Robin Wood <dninja@gmail.com>
    wifi0: ath_announce: Driver has managed mode injection patches by Jeff <dev.802.11@gmail.com>
    wifi0: ath_announce: Driver mods are maintained by H D Moore <hdm@metasploit.com>
    ath_pci: wifi0: Atheros 5424/2424: mem=0xf8000000, irq=17
    Linux kernel driver for RTL8187 based WLAN cards
    Copyright (c) 2004-2005, Andrea Merello
    rtl8187: Initializing module
    rtl8187: Wireless extensions version 22
    rtl8187: Initializing proc filesystem
    rtl8187: Enabling 14 channels.
    rtl8187: MAC chip version: 04
    rtl8187: Card type: AD
    rtl8187: Reported EEPROM chip is a 93c46 (1Kbit)
    rtl8187: Card MAC address is 00:c0:ca:1a:e7:c0
    rtl8187: RF Chip ID: 05
    rtl8187: Card reports RF frontend Realtek 8225
    rtl8187: WW:This driver has EXPERIMENTAL support for this chipset.
    rtl8187: WW:use it with care and at your own risk and
    rtl8187: WW:**PLEASE** REPORT SUCCESS/INSUCCESS TO andreamrl@tiscali.it
    rtl8187: This seems a new V2 radio
    rtl8187: PAPE from CONFIG2: 0
    rtl8187: Driver probe completed
    Linux kernel driver for RTL8187 based WLAN cards
    Copyright (c) 2004-2005, Andrea Merello
    rtl8187: Initializing module
    rtl8187: Wireless extensions version 22
    rtl8187: Initializing proc filesystem
    rtl8187: Enabling 14 channels.
    rtl8187: MAC chip version: 04
    rtl8187: Card type: AD
    rtl8187: Reported EEPROM chip is a 93c46 (1Kbit)
    rtl8187: Card MAC address is 00:c0:ca:1a:e7:c0
    rtl8187: RF Chip ID: 05
    rtl8187: Card reports RF frontend Realtek 8225
    rtl8187: WW:This driver has EXPERIMENTAL support for this chipset.
    rtl8187: WW:use it with care and at your own risk and
    rtl8187: WW:**PLEASE** REPORT SUCCESS/INSUCCESS TO andreamrl@tiscali.it
    rtl8187: This seems a new V2 radio
    rtl8187: PAPE from CONFIG2: 0
    rtl8187: Driver probe completed
    rtl8187: Card successfully reset
    rtl8187: RR:84 BRSR: 11ff
    rtl8187: RX process aborted due to explicit shutdown
    rtl8187: RX process aborted due to explicit shutdown
    rtl8187: RX process aborted due to explicit shutdown
    [drm] Initialized drm 1.1.0 20060810
    bt ~ #

    What is wrong here? I haven't installed any other driver than bt3 provide me. Maybe that's the problem?

    Thanks alot for taking your time to help a newbie like me.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •