Results 1 to 4 of 4

Thread: macchanger

  1. #1
    Junior Member
    Join Date
    May 2007
    Posts
    25

    Default macchanger

    macchanger works some-what. When I try and use the -m command it won't change the mac to what I have specified. I says "The Device is busy...". When I try to stop it with airmon it deletes the ath0 completly. Everyway I tried has it saying the device is busy. Any other thoughts? I want to change it permanetly not just temporary. Thanks

  2. #2

    Default

    Quote Originally Posted by chief30 View Post
    macchanger works some-what. When I try and use the -m command it won't change the mac to what I have specified. I says "The Device is busy...". When I try to stop it with airmon it deletes the ath0 completly. Everyway I tried has it saying the device is busy. Any other thoughts? I want to change it permanetly not just temporary. Thanks
    You are a bit sparse in your explanation of the problem. Exact commands and error responses are always preferred. But since you mention ath0, I will make the assumption that you are using madwifi-ng drivers.

    If this is the case: You need to remove any VAP's (athX) and change the MAC of wifi0, then create a new VAP using wlanconfig, adding the -uniquebssid option at the end. (you can search the forums here for a more detailed explanation).

    To make this permanent, put the commands into the rc.local file or something similar. If you don't know what rc.local does, google that as well.

    Now, with this new found info, google away and have a great time learning more about linux.

  3. #3
    Junior Member
    Join Date
    May 2007
    Posts
    25

    Default

    thank you- i'll try my best!

  4. #4

    Default

    searching out and finding the right info is part of the fun of learning. Hopefully all you needed were a few key words to put you on the right path!

    Good Luck...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •