Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [Slackware Root breaks bt3 boot permissions?]<--(new title), out of ideas.

  1. #1
    Just burned his ISO ogredeschnique's Avatar
    Join Date
    Sep 2008
    Posts
    13

    Default [Slackware Root breaks bt3 boot permissions?]<--(new title), out of ideas.

    I recently installed Slackware 12.2 on to the ssd of my eeepc. In doing this I over wrote my eeebuntu grub.
    After reinstalling bt3 to an dshc, I was able to boot once from lilo on the sdhc, before the trouble started. So I tried to add bt3 to the main SLack lilo, kernel panics galore.
    Then I put grub on the Slack ssd and created an entry for bt3.
    I added the initrd.gz from the liveUSB and I got a Permission Denied.

    Thinking about that just now, I remember that when making the lilo.conf and such in the Real Installation by pureh@te, it was necessary to chroot into the new file system.
    Also, trying to use install.sh from another linux system will yield permission denied even as root.

    But it works inside backtrack. Bt3 root user has power superseding the root users other distro's ? Well, I guess we all know that...

    Would mounting bt3 in Slackware/media/bt3 and editing the lilo.conf < not chrooted >, cause the permission denied error?
    And would editing the files like that from Slackware proper, and not chrooted, would caues more damage else where in the file system?

    Would it be easier to fix the permissions of the whole file system, because of everything that I touched trying make it boot, or to just reinstall?
    Or am I wrong about the whole permissions aspect?

    Wow, I guess I wasn't out of ideas after all. Just pondering that as I typed this post has been very educational, one way or the other.

    Any advoce or admonishment would be greatly appreciated.

    Code:
    VFS: Can not open Root device "sdb1" or unknown Block (0,0)
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount root FS on unknown-block (0,0)
    /dev/sda1(Slackware12.2)/boot/grub/menu.lst
    Code:
    title       Slackware (eeepc 16GB ssd)
    root        (hd0,0)
    kernel      /boot/vmlinuz root=/dev/sda1 ro vga=790
    
    title       bt3       (SDHC 8GB card)
    root        (hd1,0)
    kernel      /boot/vmlinuz root=/dev/sdb1 ro vga 790
    #initrd     /boot/initrd.gz  #(commented out because I was able to
    make it boot [once before I changed the default passwd] without adding
    initrd.gz from the liveCD)
    /dev/sdb1/etc/fstab (copied from /dev/sda1 modified)
    Code:
    /dev/sda1     /media/slack    ext2    defaults         1   2
    /dev/sdb1     /               ext3    defaults         1   1
    #/dev/cdrom   /mnt/cdrom      auto    noauto,owner,ro  0   0
    #/dev/fd0     /mnt/floppy     auto    noauto,owner     0   0
    devpts        /dev/pts        devpts  gid=5,mode=620   0   0
    proc          /proc           proc    defaults	       0   0
    tmpfs         /dev/shm        tmpfs   defaults	       0   0

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    I really have no clue what your trying to do but this is what it sounds like.

    You installed slackware to the internal ssd of the eeepc and that went fine. Then you did a real install of backtrack (all 2700 mb) to a sdhc card and you are trying to make that boot from lilo and you are getting a kernel panic. That is what always happens when trying to boot a real install of backtrack from removable media.
    If thats the case what you need to do is add this option to your lilo.conf

    rootdelay= 10

  3. #3
    Just burned his ISO ogredeschnique's Avatar
    Join Date
    Sep 2008
    Posts
    13

    Default

    Thank you for your reply. Stern but fair. I guess I must have forgot about it if I appended the "rootdelay=" option on the eeebuntu grub.
    It's working again now.
    Something weird that I noticed since I poseted previously,
    I had 2.6.28 on my Slackware partition.
    I over wrote the ssd with bt3 out of frustration, but lilo was not over written. I accidentially added it to the usb stick I was installing from.
    But when I tried to boot bt3 from the ssd, it booted 2.6.28 kernel even though the file system had been wiped. I tried erasing it with fdisk, and gparted from an eeebuntu liveusb. So I'm pretty sure that the fs had been removed, unless I'm having trouble with simple commands like:
    fdisk
    d
    n
    w
    mke2fs

    Or evern the gui gparted.

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Lilo will stay on the mbr until you install another boot loader or use a boot disk utility to wipe it.

  5. #5
    Just burned his ISO ogredeschnique's Avatar
    Join Date
    Sep 2008
    Posts
    13

    Default

    Yes, of course but does the kernel remain in the mbr with lilo? As far as I know the kernel should be in /boot, right? All I know is that I wiped slackware, and installed bt3 over it, but booted the 2.6.28 kernel. Unless I was actually unable to remove the partition and all of the files there in, then every tool I used in an attempt to do so is giving false feedback. [Could this have something to do with the bad Super Blocks that I'm about to mention?]

    I reinstalled Slackware and Bt3.
    I installed Grub... and added an entry for Bt3... reboot
    And nothing will boot so I booted Bt3 live from usb to fsck the partitions,
    both returning errors about a bad superblock, unmountable. So I couldn't attempt to replace lilo. [Chroot with slackware usb allowed this]

    I ran eeebuntu and bt3 side by side and never had this much trouble with kernel panics and bad super blocks.

    I appreciate your assistance.

    1. Would it help to use ext3? How can I keep from corrupting the fs? Or what will make this occur?

    <<<<<<<<<2. How can I use one boot loader for both partitions?>>>>>>>>>>>>
    [EDIT1]or mount bt3 in slackware without it going corrupt or bad superblock? I don't know what I'm doing to make this happen.
    [EDIT2] I used 'touch forcefsck' and Slackware boots again after CHroot with slackware usb and remade lilo.

  6. #6
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    I'm not sure what the problem is exactly but yes you can boot 2 OS's from grub just fine. I think your getting confused with using to many boot loaders. Pick one and stick with it. Lilo is the easiest to use so I would use that.

    So install slackware on the hard disk and get that booting and working correctly before trying anything else. Once you do that then you can manually copy the bt3 files to the SD cardand just dont install a boot loader to the SD card. Then point your bootloader drom the slackware install at the bt3 disk. The sd card doesnt need a bootloader. I would stick with Lilo as its easier to use than grub in my opinion. Make sure you use a linux filesystem on the sd card by the way.

  7. #7
    Just burned his ISO ogredeschnique's Avatar
    Join Date
    Sep 2008
    Posts
    13

    Default

    {Could you change the title to this to something like "[SOLVED] Trouble dual booting Slackware and BT3 (SDHC) on eeepc". That would be more representative of the actual thread and less confusing for others.}

    On my main machine I have 5 OSs booting from grub. I understand that it is possible.

    My desire to use grub in this situation stems from confusion because:
    A few times near the end when I had the 2.8.28 kernel on slackware, and tried to boot bt3 and it would load the slackware 2.8.28 kernel (I don't know why), then the initrd and then kernel panic with the same message.
    So... I thought that the "boot=" option at the beginning of the lilo.conf was relative to the "image=" option on the individual entries, rather than the "root=".
    To me, it seemed that the "image=" was looking in the "boot=", but I'm sure I had a misconfigured lilo.conf.

    Current lilo.conf
    Code:
    boot = /dev/sda
      bitmap = /boot/slack.bmp
      bmp-colors = 255,0,255,0,255,0
      bmp-table = 60,6,1,16
      bmp-timer = 65,27,0,255
    append=" vt.default_utf8=0"
    prompt
     vga=773
    
    image = /boot/vmlinuz
      root = /dev/sda1
      label = Slackware12.2
      read-only
    
    image = /boot/vmlinuz
      root = /dev/sdb1
      label = BT3
      append=" rootdelay=10"
      read-only
    Yields this error
    Code:
    md: autorun ...
    md: ... autorun DONE.
    VFS: Cannot open root device "811" or unknown-block(8,17)
    Please append a correct "root=" boot option; here are the available partitions:
    0800     15761088 sda driver: sd
      0801 15759733 sda1
    Kernel panic - not syncing : VFS: Unable to mount root fs ono unknown-block(8,17)
    The card is Verbatim SDHC Premium 16GB Class 6.
    EeePC 900 16GB ssd.

    [EDIT] I must say that I really appreciate your patient assistance. One question remains and THink I know the answer to it.

    Is it necessary to run "lilo" after ?every? edit of the lilo.conf to see the results?
    It's not such a big deal, so long as you remember it, if that is the case.
    I guess I'm used to grub, which does not require this.

    I'm able to boot bt3 now and Slackware from lilo. If the above revelation is the case, I feel foolish but still feel the satisfaction of learning something.
    Thanks again.[/EDIT]

  8. #8
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    your problem is you have two different kernels named the same thing!

    image = /boot/vmlinuz
    root = /dev/sda1
    label = Slackware12.2
    read-only


    image = /boot/vmlinuz
    root = /dev/sdb1
    label = BT3
    append=" rootdelay=10"
    read-only

    boot = /dev/sda << at this line you are telling the boot loader where to look (sda) for the kernel however the kernel for both OS's is called the same thing so its confused.

    Try doing this
    image = /dev/sdb1/boot/vmlinuz
    root = /dev/sdb1
    label = BT3
    append=" rootdelay=10"
    read-only

    image = /dev/sda1/boot/vmlinuz
    root = /dev/sda1
    label = Slackware12.2
    read-only

    Its also not clear if you have a /boot partiton or if the whole OS is on one partition only? root = should be the partiton where your / (root) file system is not the one where your kernel is unless they are the same partition.

  9. #9
    Just burned his ISO ogredeschnique's Avatar
    Join Date
    Sep 2008
    Posts
    13

    Default [solved]

    Both Slack And Backtrack are both on 1 partition... each.

    Most Appreciated. That completely resolves my issues as far as I can tell.
    Thank you once more.

  10. #10
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Excellent! Glad I could help.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •