Results 1 to 7 of 7

Thread: Startx problems

  1. #1
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    7

    Default Startx problems

    I started Backtrack 3 with no problems. After i logged in as root, just for fun i typed xconf, and then startx.
    I normally don't do that. And i could normally do the startx with no problems.
    When i typed startx it gave me an error:

    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!!) notice, (II) informational,
    (ww) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 1 18:00:01 2009
    (==) Using config file: "/etc/X11/xorg.conf"
    (WW) intel: No matching Device section for instance (BusID PCI:0:2:1) found
    (II) Module already built-in
    (II) Module already built-in
    (II) Module already built-in
    (EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
    (EE) intel(0): Couldn't allocate video memory

    Fatal server error:
    AddScreen/ScreenInit failed for driver 0

    giving up
    xinit: Connection reset by peer /errno 104): unable to connect to X server
    xinit: No such process (errno 3): Server error.


    Sorry for my bad english

  2. #2
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Default

    use fixvesa command.

  3. #3
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    7

    Default

    Thank you so much

  4. #4
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    2

    Default

    I've got the same problem, but when I type in 'fixvesa' then startx, my monitor shows a message saying input not supported. Any solutions?

  5. #5
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    2

    Default

    I've got the same problem, but when I type 'fixvesa' then 'startx' my monitor shows a message saying 'input not supported'. I've tried the 'vesa kde' but to no avail. Any solutions.

  6. #6
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by tony123 View Post
    I've got the same problem, but when I type 'fixvesa' then 'startx' my monitor shows a message saying 'input not supported'. I've tried the 'vesa kde' but to no avail. Any solutions.
    Xorg is setting up the display with the wrong monitor settings. Google xorg.conf with your monitor's name.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  7. #7
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Slackbook contains some excellent information about the xserver and configuring it. Also I did a small tutorial about getting an external monitor setup using #xorgconfig a while back. The problem you are most likely having is just what Barry said. If you don't have your monitor doc then you can google it.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •