Results 1 to 4 of 4

Thread: ERROR while getting interface flags: No such device

  1. #1
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    18

    Default ERROR while getting interface flags: No such device

    Right, another noob here.
    First of all, I managed to crack WEP with this same card on BackTrack 2. Now I just updated Backtrack to version 3 Final, and I can't crack WEP anymore.. Very odd !

    Now, whenever I try to crack wep using BackTrack 3 final, I do the following:

    bt ~: airmon-ng stop ath0
    bt ~: ifconfig ath0
    BASH: ERROR while getting interface flags: No such device

    I googled and found something in the aircrack-ng wiki about installing drivers (Madwifi-Drivers in my case), but I'm wondering if this is neccesary at all in my case ? Because I'm able to connect to the internet using the Wireless Assistant without problems (which means the card is recognized, right ?)...

    Anyway, neccesary or not, I tried installing them using the following tutorial: I untarred the madwifi drivers and went to the folder and typed make. I got the error which is listed on top of the page:
    /lib/modules/2.6.24-19-server/build is missing, please set KERNELPATH.

    I tried fixing it with the command give as solution to this problem:
    sudo apt-get install linux-headers-$(uname -r)

    But that didn't work either. I got a bash error, command not found...
    Now Im totally stuck.. bit frustrated, don't understand why I just could plugin my card in BT2 and start cracking but in BT3 I need to install drivers and such...

    My card is a TP-Link TL-WN610G based on an Atheros chipset. I'm running Backtrack 3 Final

    Thanks in advance !

  2. #2

    Default

    do you even know, which device is your wlan?

  3. #3
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    18

    Default

    Thanks for your reply !

    ath0 is my wlan device so that should be okay..

  4. #4
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    18

    Default

    Update:

    It worked out. It appears that my driver's card (madwifi-ng) isn't compatible with the method used in all tutorials on youtube (sucky sucky I know ).
    Therefore I need to run a script instead of typing --macchanger etc.

    For future references: The script can be found here: hxxp://www .aircrack-ng.org/doku.php?id=faq&s=macchanger (scroll down, script 2 written by audax.)

    How to use can be found here: hxxp://www .ax697.org/writing-a-basic-ubu...00786.html]

    Thanks for the support !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •