i use bt3 on the eeepc 701.

i successfully extracted the wep 128 bit wep key from my own wlan but i cannot connect from the backtrack 3 system via console or wireless assistant gui.

my net: KEY FOUND! [ 37:31:30:37:33:32:32:38:35:33:36:36:xx ]..


bt # iwconfig ath0 mode managed
bt # iwconfig ath0 essid "my net"
bt # iwconfig ath0 key xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx open
bt # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"my net" Nickname:""
Mode:Managed Frequency:2.437 GHz Access Point: 00:1C:4A:09:D8:5E
Bit Rate:36 Mb/s Tx-Power:17 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:3731-3037-3332-3238-3533-3636-xx Security mode:open
Power Management:off
Link Quality=14/70 Signal level=-82 dBm Noise level=-96 dBm
Rx invalid nwid:1249 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

bt # dhclient ath0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.


wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:15:af:8c:f7:83
Sending on LPF/ath0/00:15:af:8c:f7:83
Sending on Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 8

again iwconfig

bt sda1 # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"mynet" Nickname:""
Mode:Managed Frequency:2.437 GHz Access Point: 00:1C:4A:09:D8:5E
Bit Rate:1 Mb/s Tx-Power:17 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:3731-3037-3332-3238-3533-3636-xx Security mode:open
Power Management:off
Link Quality=16/70 Signal level=-79 dBm Noise level=-95 dBm
Rx invalid nwid:11788 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

so dhclient fails, dhcpcd fails and manual ip configuration fails either.
the wep key is correct.. i can connect from other systems via this wep key.

can anyone help me with this ?