Results 1 to 8 of 8

Thread: metasploit wont update:error

Hybrid View

  1. #1
    Senior Member BigMac's Avatar
    Join Date
    Jan 2008
    Posts
    213

    Default metasploit wont update:error

    when i run the update script located
    <KDE>backtrack>penitation>framework version3>metasploit3 update>

    this is the error i get
    svn: Working copy 'data/msfweb/vendor/rails/activerecord/lib' is not locked

    i seen some new exploits on the metasploit framework site, its been weeks since i was able to update metasploit in backtrack3f... any ideas on why lib is locked?

    edit: im a dumb dumb
    svn co http://metasploit.com/svn/framework3/trunk msf3

  2. #2
    Just burned his ISO
    Join Date
    Oct 2008
    Posts
    14

    Default

    just out of interest have you tried to update it through fasttrack?

    kde>backtrack>penetration>fasttrack>option 1 option1

    let me know if it works that way if not you can load the updates through the msf console, cheers

    after one of my udates stalled i tried this and it worked,

    svn --config-dir svnconf framework cleanup svn --config-dir svnconf framework update

    good luck

  3. #3
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Default

    Using ezpawn tool you can update aircrack-ng,milw0rm database,metasploit easily.

  4. #4
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    2

    Default

    - Go to /pen*/exploit*/framework
    - then just type : # svn update

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by thecaller View Post
    - Go to /pen*/exploit*/framework
    - then just type : # svn update
    The thread is six months old, good dig.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  6. #6
    Just burned his ISO
    Join Date
    Feb 2009
    Posts
    11

    Talking

    I do have the same situation, get disconnected while updating msf3 on BT4pf, let me rephrase the situation again,

    Got disconnected while updating, try to run fasttrack with option "2. Metasploit 3 Update" again, the output :

    Enter number: 2
    Configuration file not detected, running default path.
    Recommend running setup.py install to configure Fast-Track.
    Updating Metasploit....
    svn: Working copy '/pentest/exploits/framework3' locked
    svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
    Okay, seems svn appears to fix this, navigate to cd/pen*/explo*/frame*# svn cleanup, the output :

    vn: In directory 'lib'
    svn: Error processing command 'modify-wcprop' in 'lib'
    svn: 'lib/readline_compatible.rb' is not under version control
    Doesn't work anyway, on the other thread, suggest cd /pentest/svn/framework3 && svn cleanup or /pen*/exploit*/framework# svn update (here in this thread), the output :

    svn: Working copy '.' locked
    svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
    Doesn't work either, BigMac temporary solutions with "svn co http ://metasploit.com/svn/framework3/trunk msf3", the output :

    ...
    ...
    Checked out revision 8044.
    Add info 1 :
    But ..., back to cd /pen*/expl*/framework3 # ./msfconsole, an error occur, the output :
    /pentest/exploits/framework3/lib/msf/core/exploit/mysql.rb:18:in `requir e': no such file to load -- rbmysql (LoadError)
    from /pentest/exploits/framework3/lib/msf/core/exploit/mysql.rb: 18
    from /pentest/exploits/framework3/lib/msf/core/exploit/mixins.rb :28:in `require'
    from /pentest/exploits/framework3/lib/msf/core/exploit/mixins.rb :28
    from /pentest/exploits/framework3/lib/msf/core/exploit.rb:215:in `require'
    from /pentest/exploits/framework3/lib/msf/core/exploit.rb:215
    from /pentest/exploits/framework3/lib/msf/core.rb:49:in `require '
    from /pentest/exploits/framework3/lib/msf/core.rb:49
    from /pentest/exploits/framework3/lib/msf/ui/console/driver.rb:1 :in `require'
    from /pentest/exploits/framework3/lib/msf/ui/console/driver.rb:1
    from /pentest/exploits/framework3/lib/msf/ui/console.rb:10:in `r equire'
    from /pentest/exploits/framework3/lib/msf/ui/console.rb:10
    from /pentest/exploits/framework3/lib/msf/ui.rb:10:in `require'
    from /pentest/exploits/framework3/lib/msf/ui.rb:10
    from ./msfconsole:16:in `require'
    from ./msfconsole:16
    what about the fasttrack update ? Doesn't work either, seems agreed by RageLtMan too.

  7. #7
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  8. #8
    Just burned his ISO
    Join Date
    Nov 2009
    Posts
    2

    Default

    i had some problem downloading from svn
    connection just hang up sometime
    but no problem when i used proxy
    looks like my isp block traffic to the metasploit svn...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •