Okay, Before you tell me to go search and read and scream about searching, ive already done all the searching I can handle. I have a few questions, if anyone would be so kind to answer, id greatly appreciate.

First. System is a
DV9927... Turion 64, 4 Gigs of ram, 500 gig hd dual boot vista/bt3. the HD install was fairly simple following one of the guides around here. I had gone through a very similar install process with gentoo pre auto-installer


at the end of this post I will post all releveant information on the system


First Question I have

other then the broadcom restricted driver. is there a driver for a broadcom 4322ag card. I was able to get the card installed using broadcrom driver, but it does not support injection. I am not able to use airodump. when I do airodump, my output is

bt Main # airodump-ng eth1
ioctl(SIOCSIWMODE) failed: Invalid argument

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead. Make
sure RFMON is enabled: run 'airmon-ng start eth1 <#>'
Sysfs injection support was not found either.

bt Main #
these are the instructions i followed to get the card working
hxxp://www-dot-broadcom-dot-com/docs/linux_sta/README.txt
Question #2

I have 4 gigs of ram installed, BT only shows 3. Is that because bt is 32bit? I have the same problem using vista 32, it only shows 3 gigs, I am positive I have 4.

Question #3
I was able to get NVIDIA driver working without a problem, fairly simple to setup. Where is there a sticky or step by step tutorial on getting compiz going without having to upgrade to kde4.

Question #4
considering i have 3 gigs of usable ram, should I reallly have 6 gig swap space? I havnt used a meg of swap in the last 48 hours and i have stressed test the system on what my normal usage will be

Question #5
I want to TrueCrypt my entire bt3 install. I followed the instructions on compiling truecrypt. after i run the aplication I am told that I need to upgrade the kernel which I will be doing next. I dont need help compiling and installing kernel. My question is. How can I keep bt3 totally encrypted with true crypt but have windows with no encryption. I want truecrypt to ask for pw on boot for true crypt. no pw for vista

another scenerio i wouldnt mind. have lilo on mbr ask me if i want to boot into vista or bt3, if bt3 is picked. then some sort of truecrypt authentication beings. is this possible?

Question #6
When I boot bt, it starts as a blank screen until I press the power button then the bootup process continues. I read and followed the instructions on this issue on noacpi. now my screen does not go blank, but it gets stuck on loading fd0 (i dont have a floppy drive) until i press the power button again, and then it will continue loading.

If there are any articles that will give me more insight on what im trying to accomplish. please point.

my lspci output
00:00.0 RAM memory: nVidia Corporation Unknown device 0547 (rev a2)
00:01.0 ISA bridge: nVidia Corporation Unknown device 0548 (rev a2)
00:01.1 SMBus: nVidia Corporation Unknown device 0542 (rev a2)
00:01.2 RAM memory: nVidia Corporation Unknown device 0541 (rev a2)
00:01.3 Co-processor: nVidia Corporation Unknown device 0543 (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:04.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:04.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP67 IDE Controller (rev a1)
00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation Unknown device 0561 (rev a2)
00:09.0 IDE interface: nVidia Corporation Unknown device 0550 (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation Unknown device 054c (rev a2)
00:0c.0 PCI bridge: nVidia Corporation Unknown device 0563 (rev a2)
00:0d.0 PCI bridge: nVidia Corporation Unknown device 0563 (rev a2)
00:12.0 VGA compatible controller: nVidia Corporation Unknown device 0531 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:05.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
02:05.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
02:05.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
02:05.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
02:05.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
03:00.0 Network controller: Broadcom Corporation Unknown device 432b (rev 01)
my disk setup
Device Boot Start End Blocks Id System
/dev/sda1 * 1 12749 102400000 7 HPFS/NTFS
/dev/sda2 12749 28706 128179200 7 HPFS/NTFS
/dev/sda3 28707 30401 13615087+ 7 HPFS/NTFS

Device Boot Start End Blocks Id System
/dev/sdb1 1 12749 102400000 7 HPFS/NTFS (vista)
/dev/sdb2 12749 12799 406943+ 83 Linux
/dev/sdb3 12800 13596 6401902+ 82 Linux swap
/dev/sdb4 13597 30401 134986162+ 83 Linux
my iwconfig output
lo no wireless extensions.

eth0 no wireless extensions.

tun0 no wireless extensions.

eth1 IEEE 802.11abgn ESSID:"" Nickname:""
Mode:Managed Frequency:2.457 GHz Access Point: Not-Associated
Bit Rate=44 Mb/s Tx-Power:32 dBm
Retry min limit:7 RTS thrff Fragment thrff
Power Managementmode:All packets received
Link Quality=5/5 Signal level=-256 dBm Noise level=-93 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0