Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: error:Neither the sysfs interface links nor the iw command is available.

  1. #1
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    15

    Default error:Neither the sysfs interface links nor the iw command is available.

    When I run the command "airmon-ng start wlan0" i get the following error message.

    "Neither the sysfs interface links nor the iw command is available.
    Please download and install iw from http: //dl.aircrack-ng.org/iw.tar.bz2

    i downlaoded the cd image from
    remote-exploit.org/backtrack_download.html
    and i am booting of the cd.

    btw i have searched this forum and found about 3-4 other threads like this but they dont seem to be helping me. can someone tell me what im suppose to do after downlaod the file "(http: //dl.aircrack-ng.org/iw.tar.bz2)"

    thanks in advance

  2. #2
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    6

    Unhappy

    Same problem here, i am noob with this updating, could anyone direct me to some thread about this, im not exactly sure what this even is.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    6

    Default same

    Same problem here, im noob with this updating, and i do not know exactly what i am doing..so if this thread already exist could someone redirect me to it.
    Many thanks.
    ReQ.

  4. #4
    Junior Member
    Join Date
    Sep 2008
    Posts
    30

    Default

    What wireless card to you have?

    ususally im doing airmon-ng start wifi0 (wifi0 being the interface)

    sounds to me like wlan0 isnt in you interface list. type iwconfig to check interface first

  5. #5
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    6

    Default

    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"xxx" Nickname:""
    Mode:Managed Frequency:2.437 GHz Access Point: xxx
    Bit Rate=54 Mb/s Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2346 B
    Encryption key:xxxx

    i do have wlan0 as my device name, im using intel PRO/wireless 3945ABG card
    i just need to install that file and i dont know how

  6. #6
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    6

    Default

    i think i found my fix here:showthread.php?t=12165&highlight=3945 (cant post links yet) but search ftw

  7. #7
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    15

    Default

    im also using intel PRO/wireless 3945 A/B/G card. its built into my laptop. i was wondering if any1 that has got this to work could u pls upload ur version of ur bootable disk here, very much appriciated.

    thanks in advance

  8. #8
    Junior Member
    Join Date
    Sep 2008
    Posts
    30

    Default

    Requish is right with the fourm

    i have the same card, to enable monitor mode i type the following

    iwconfig
    shows the interface is wlan0
    modprobe -r iwl3945 tells backtrack to dismount iwl3945 driver
    modprobe ipwraw tells backtrack to load ipwraw driver
    airmon-ng start wifi0 use interface wifi0 at this point as last 2 steps changed it

  9. #9
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    15

    Default

    thnks theoleek, that makes a lot more sens then what it says on that thread requish. as u can see im a noob when it comes to backtrack 3 and linux

  10. #10
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    6

    Default

    however...this results in anoter error. In that ipwraw driver mode , my wlan card is unable to find any networks. When i changed back to old driver , it was able to find wireless networks, but again was unable to start airmon-ng (same error as before)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •