Results 1 to 2 of 2

Thread: BT3 + AR50007EG, Some hurdles

  1. #1
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    1

    Question BT3 + AR50007EG, Some hurdles

    Ill keep it as brief as possible:

    Ive got BT3 booting from my USB stick, using the extended version. My laptop, a Samsumg SA1, has an Atheros AR5007EG chipset according to Windows Vista. What I have done so far:

    - downloaded, compiled and installed the newest madwifi + hal drivers. even though i have chosen the 'persistent changes' option during startup for BT3, does this persist when i reboot for the changes to take effect?

    - tried to load the included ath_pci module (modprobe ath_pci). this throws no errors, but ifconfig and iwconfig both show nothing about my card. lsmod shows that ath_pci and its related modules are indeed loaded.

    here is the relevant info from lspci -v:
    Code:
    02:00.0 Ethernet controller: Unknown device 0001:001c (rev 01)
    	Subsystem: Askey Computer Corp. Unknown device 7131
    	Flags: bus master, fast devsel, latency 0, IRQ 10
    	Memory at e8100000 (64-bit, non-prefetchable) [size=64K]
    	Capabilities: [40] Power Management version 2
    	Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
    	Capabilities: [60] Express Legacy Endpoint IRQ 0
    	Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
    	Capabilities: [100] Advanced Error Reporting
    	Capabilities: [140] Virtual Channel
    and the relevant info from scanpci -v:
    Code:
    pci bus 0x0002 cardnum 0x00 function 0x00: vendor 0x168c device 0x001c
     Atheros Communications, Inc.  Device unknown
     CardVendor 0x144f card 0x7131 (Card unknown)
      STATUS    0x0010  COMMAND 0x0007
      CLASS     0x02 0x00 0x00  REVISION 0x01
      BIST      0x00  HEADER 0x00  LATENCY 0x00  CACHE 0x08
      BASE0     0x00000000e8100004  addr 0x00000000e8100000  MEM 64BIT
      MAX_LAT   0x00  MIN_GNT 0x00  INT_PIN 0x01  INT_LINE 0x0a
      BYTE_0    0x01  BYTE_1  0x50  BYTE_2  0xc2  BYTE_3  0x41
    and finally, the output from ath_info 0xe8100000:
    Code:
     -==Device Information==-
    MAC Version:  2425  (0xe0)
    MAC Revision: 2425  (0xe2)
    Warning: Invalid EEPROM Magic number!
    Device type:  3
    
    /============== EEPROM Information =============\
    | EEPROM Version:   5.3 | EEPROM Size:   4 kbit |
    | EEMAP:              2 | Reg. Domain:     0x65 |
    |================= Capabilities ================|
    | 802.11a Support:  no  | Turbo-A disabled: yes |
    | 802.11b Support:  no  | Turbo-G disabled: yes |
    | 802.11g Support:  yes | 2GHz XR disabled: yes |
    | RFKill  Support:  yes | 5GHz XR disabled: yes |
    | 32kHz   Crystal:  no  |                       |
    \===============================================/
    
    /=========================================================\
    |          Calibration data common for all modes          |
    |=========================================================|
    |          CCK/OFDM gain delta:             1             |
    |          CCK/OFDM power delta:            5             |
    |          Scaled CCK delta:                5             |
    |          2GHz Antenna gain:               1             |
    |          5GHz Antenna gain:               4             |
    |          Turbo 2W maximum dBm:           38             |
    |          Target power start:          0x16e             |
    |          EAR Start:                   0x1c8             |
    \=========================================================/
    
    /=========================================================\
    |          Calibration data for 802.11g operation         |
    |=========================================================|
    | I power:              0x00 | Q power:              0x10 |
    | Use fixed bias:       0x01 | Max turbo power:      0x26 |
    | Max XR power:         0x24 | Switch Settling Time: 0x28 |
    | Tx/Rx attenuation:    0x19 | TX end to XLNA On:    0x00 |
    | TX end to XPA Off:    0x00 | TX end to XPA On:     0x0e |
    | 62db Threshold:       0x1c | XLNA gain:            0x00 |
    | XPD:                  0x01 | XPD gain:             0x0a |
    | I gain:               0x00 | Tx/Rx margin:         0x01 |
    | False detect backoff: 0x00 | Noise Floor Threshold:  -1 |
    | ADC desired size:      -38 | PGA desired size:      -80 |
    |=========================================================|
    | Antenna control   0:  0x00 | Antenna control   1:  0x01 |
    | Antenna control   2:  0x22 | Antenna control   3:  0x22 |
    | Antenna control   4:  0x00 | Antenna control   5:  0x00 |
    | Antenna control   6:  0x02 | Antenna control   7:  0x21 |
    | Antenna control   8:  0x21 | Antenna control   9:  0x00 |
    | Antenna control  10:  0x00 | Antenna control  11:  0x02 |
    |=========================================================|
    | Octave Band 0:           3 | db 0:                    3 |
    | Octave Band 1:           4 | db 1:                    4 |
    | Octave Band 2:           0 | db 2:                    0 |
    | Octave Band 3:           0 | db 3:                    0 |
    \=========================================================/
    /============== Per rate power calibration ===========\
    | Freq | 6-24Mbit/s | 36Mbit/s |  48Mbit/s | 54Mbit/s |
    |======|============|==========|===========|==========|
    | 2412 |    18.00   |  17.00   |   15.01   |  13.01   |
    |======|============|==========|===========|==========|
    | 2437 |    18.00   |  17.00   |   15.01   |  13.01   |
    |======|============|==========|===========|==========|
    | 2472 |    18.00   |  17.00   |   15.01   |  13.01   |
    \=====================================================/
    /=================== Per channel power calibration ====================\
    | Freq | pwr_0 | pwr_1 | pwr_2 | pwr_3 |pwrx3_0|pwrx3_1|pwrx3_2|max_pwr|
    |      | pcdac | pcdac | pcdac | pcdac | pcdac | pcdac | pcdac |       |
    |======|=======|=======|=======|=======|=======|=======|=======|=======|
    | 2412 | 25.02 |  9.02 |  0.00 | 25.02 |  0.00 |  0.00 | 34.01 | 25.02 |
    |      | [112] | [112] | [112] | [112] |  [20] |  [35] |  [63] |       |
    \======================================================================/
    
    GPIO registers: CR 0x00008000, DO 0x00000000, DI 0x00000003
    STA_ID0: 00:21:63:1c:32:87
    STA_ID1: 0x00008732, AP: 0, IBSS: 0, KeyCache Disable: 0
    TIMER0: 0x00000030, TBTT:    48, TU: 0x00010030
    TIMER1: 0x0007ffff, DMAb: 65535, TU: 0x0000ffff (-49)
    TIMER2: 0x01ffffff, SWBA: 65535, TU: 0x003fffff (+4128719)
    TIMER3: 0x00000031, ATIM:    49, TU: 0x00010031 (+1)
    TSF: 0x00000000031ea07c, TSFTU: 51112, TU: 0x0000c7a8
    BEACON: 0x00000000
    LAST_TSTP: 0x40088800
    It seems there is something strange going on with the vendor / chipset id here. Do i have it wrong? Is this really some other chipset? What should I try next to get the madwifi drivers to load, if that is indeed the problem?

    thanks very much

  2. #2
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    You need a specific version of madwifi's HAL, 10.x or above and it won't work with certain modes:
    http://ubuntuforums.org/showthread.php?t=792158

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •