Results 1 to 2 of 2

Thread: Intel 5300 AGN compatibility with BT3

  1. #1
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    4

    Default Intel 5300 AGN compatibility with BT3

    My question is, where could I go from here? Is it easier to try and update the BT3 Kernel will that mess other things up. Can the error below be resolved, something i'm doing wrong during the make? If you have any suggestions i'd appreciate it. Been using BT for awhile now, big fan!

    Just bought a new laptop Lenovo W500, upgraded the wifi to the Intel 5300 AGN card. It doesn't show up in iwconfig/ifconfig... After doing some research it seems it works natively with the latest version of Ubuntu (this is due to their latest kernel.) I think iwlagn it uses?


    Intel Corporation Unknown device [8086:4235]
    I thought this site would work as it makes drivers for older kernels which bt3 runs off of: linuxwireless.org

    Anyway I tried d/l and extracted the compat-wireless-2.6-old/ and did a:
    make

    but it errors out:


    bt compat-wireless-2.6-old # make
    make -C /lib/modules/2.6.21.5/build M=/mnt/sda4/wifidrivers/compat-wireless-2.6-old modules
    make[1]: Entering directory `/usr/src/linux-2.6.21.5'
    CC [M] /mnt/sda4/wifidrivers/compat-wireless-2.6-old/drivers/misc/eeprom_93cx6.o
    In file included from <command line>:1:
    /mnt/sda4/wifidrivers/compat-wireless-2.6-old/include/net/compat.h:32:26: error: linux/rfkill.h: No such file or directory
    In file included from <command line>:1:
    /mnt/sda4/wifidrivers/compat-wireless-2.6-old/include/net/compat.h:124: error: static declaration of 'pci_set_mwi' follows non-static declaration
    include/linux/pci.h:538: error: previous declaration of 'pci_set_mwi' was here
    /mnt/sda4/wifidrivers/compat-wireless-2.6-old/include/net/compat.h:129: error: static declaration of 'pci_clear_mwi' follows non-static declaration
    include/linux/pci.h:539: error: previous declaration of 'pci_clear_mwi' was here
    In file included from <command line>:1:
    /mnt/sda4/wifidrivers/compat-wireless-2.6-old/include/net/compat.h:806: warning: 'enum rfkill_state' declared inside parameter list
    /mnt/sda4/wifidrivers/compat-wireless-2.6-old/include/net/compat.h:806: warning: its scope is only this definition or declaration, which is probably not what you want
    /mnt/sda4/wifidrivers/compat-wireless-2.6-old/include/net/compat.h:806: warning: 'struct rfkill' declared inside parameter list
    make[3]: *** [/mnt/sda4/wifidrivers/compat-wireless-2.6-old/drivers/misc/eeprom_93cx6.o] Error 1
    make[2]: *** [/mnt/sda4/wifidrivers/compat-wireless-2.6-old/drivers/misc] Error 2
    make[1]: *** [_module_/mnt/sda4/wifidrivers/compat-wireless-2.6-old] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.21.5'
    make: *** [modules] Error 2

  2. #2
    Member
    Join Date
    Jun 2008
    Posts
    129

    Default

    Probably easier to install a new kernel. I upgraded to 2.6.27.4 using this tutorial
    hxxp://forums.remote-exploit.org/showthread.php?t=13426
    It does have the 5000 series drivers in it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •