Results 1 to 8 of 8

Thread: Setting Resolution On Nvidia Cards

  1. #1
    fastboi
    Guest

    Question Setting Resolution On Nvidia Cards

    I just did a fresh bt3f install on my hdd (dual boot with vista). I also used bt3 usb edition loaded from usb stick to do actual installation. I picked nvidia experimental option. It was not working so i installed 177.x.x.x drivers and it solved the problem, however it created new one. I get only one resolution option (1920x1200), and thats way to small. I do not want to go blind at a young age lol So may you guys tell me of how can i change it.

    Appreciate that,

    Fastboi

    edit: Some views and no answer. Maybe i was not clear, so lets rephrase it little bit lol It's not like there is a lot of resolutions options, i am not THAT NOOBIE, but really in resolution option menu there is only one resolution option of 1920x1200. Cmon guys, save my eyes please lol

  2. #2
    fastboi
    Guest

    Default

    50 or so hits and no answer? I tried nvidia-settings but still i can only get 1900x1200. I also tried adding modes "1600x1200" and etc to xorg.conf but it did not helped either. Anyone?

  3. #3
    fastboi
    Guest

    Default

    bumb... please?

  4. #4
    Member imported_Deathray's Avatar
    Join Date
    Oct 2007
    Posts
    381

    Default

    I few months ago I had the same problem.
    What you want to look into is the xorg.conf file. That was what I configured to solve my problem.

    That's as much as I can help you unfortunately. Goodluck (: !
    - Poul Wittig

  5. #5
    Member MosGuy's Avatar
    Join Date
    Jan 2010
    Location
    Ontario, Canada
    Posts
    120

    Default

    I had a similar issue back with BT2, though mine was the opposite. I had a lower resolution & I wanted my laptop at its native 1920x1200. What I ended up doing was: manually editing the xorg.conf, with all the various resolutions I wanted. Then re-running the nvidia driver install/setup. After that the list of resolutions finally came up. Again that was with version 2, I've never had issues with v3 beta or final. It might be worth a try though.

  6. #6
    fastboi
    Guest

    Default

    Quote Originally Posted by MosGuy View Post
    I had a similar issue back with BT2, though mine was the opposite. I had a lower resolution & I wanted my laptop at its native 1920x1200. What I ended up doing was: manually editing the xorg.conf, with all the various resolutions I wanted. Then re-running the nvidia driver install/setup. After that the list of resolutions finally came up. Again that was with version 2, I've never had issues with v3 beta or final. It might be worth a try though.
    Lets start with... what video card do you own? Also, may you post yours xorg.conf? I actually added Modes "1280x1024" to the section Screen...

    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024"
    EndSubSection

    I guess i should be getting that resolution but i am not.
    My laptop is working at a depth of 24 according to nvidia x server settings, so i am in the right place.
    Is only xorg.conf file needs to be configured, or some other configs as well?
    Do you remember what exact fields you edited?

  7. #7
    Member MosGuy's Avatar
    Join Date
    Jan 2010
    Location
    Ontario, Canada
    Posts
    120

    Default

    Quote Originally Posted by fastboi View Post
    Lets start with... what video card do you own? Also, may you post yours xorg.conf? I actually added Modes "1280x1024" to the section Screen...

    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024"
    EndSubSection

    I guess i should be getting that resolution but i am not.
    My laptop is working at a depth of 24 according to nvidia x server settings, so i am in the right place.
    Is only xorg.conf file needs to be configured, or some other configs as well?
    Do you remember what exact fields you edited?
    I have a Dell with a NV Quadro FX go700 w/128MB. If I remember right I simply took the Display lines you listed above & just altered the various resolution sizes. I don't recall editing any other files. Though note: simply editing the Xorg file & rebooting didn't add the various resolutions to the list. The key for me was re-running the NV driver /setup again i.e: from scratch as if they weren't already installed.

    I can try & dig out my BT2 CD, or see if BT3 lists any other resolutions. BT3 loaded to 1920x1200 which is what I wanted. I had no need to see if I have any lower resolutions listed. I'd try re-running the drivers again, if you haven't already.

    Update: I just checked BT3, all resolutions are listed. Out of the box without installing any NV drivers. I've listed my Xorg file below:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Apr 16 20:37:13 PDT 2007
    
    Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/share/X11/rgb"
        ModulePath      "/usr/lib/xorg/modules"
        FontPath        "/usr/share/fonts/TTF"
        FontPath        "/usr/share/fonts/OTF"
        FontPath        "/usr/share/fonts/Type1"
        FontPath        "/usr/share/fonts/misc"
        FontPath        "/usr/share/fonts/75dpi/:unscaled"
    EndSection
    
    Section "Module"
        Load           "glx"
        Load           "dbe"
        Load           "extmod"
        Load           "record"
        Load           "xtrap"
        Load           "freetype"
        Load           "type1"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/input/mice"
        Option         "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Monitor Vendor"
        ModelName      "Monitor Model"
    EndSection
    
    Section "Device"
        Identifier     "Card0"
        Driver         "nvidia"
        VendorName     "nVidia Corporation"
        BoardName      "NVIDIA Quadro FX Go700"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Card0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "RenderAccel" "True"
        Option         "AllowGLXWithComposite" "True"
        Option         "AddARGBGLXVisuals" "True"
        Option         "DisableGLXRootClipping" "True"
        SubSection     "Display"
            Viewport    0 0
            Depth       1
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       4
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       8
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       15
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       16
        EndSubSection
        SubSection     "Display"
            Viewport    0 0
            Depth       24
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection

  8. #8
    fastboi
    Guest

    Default

    so with this xorg.conf i bet you are getting 1920x1200 by default and it gives you no other options right?

    edit: ok after messing around with xorg.conf at least i found out how to increase my resolution.

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "NoLogo" "1"
    Option "Coolbits" "1"
    Option "TripleBuffer" "1"
    Option "AddARGBGLXVisuals" "1"
    Option "DamageEvents" "1"
    Option "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection

    If i change +0+0, to let say +100+100 i would be getting 2020x1320. When i found out this trick, i thought yeahhhh all i need to do is -320+0 to get 1600x1200, but it did not work and i am stuck again. Can anybody please help? I been trying to get other options than 1920x1200 for hours with no success... EDIT: it actually was not resolution change... it was PANNING of the 1920x1200 resolution.

    edit: solved. i was looking like crazy in google, and forgot about search option here. Browsed all topics with resolution word in it. Found purehates posted link. http://www.bohne-lang.de/spec/linux/modeline/. Used it... it generated code, and i pasted it in xorg.conf....

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "AUO"
    HorizSync 30.0 - 75.5
    VertRefresh 62.0
    Option "DPMS"
    Modeline "1280x960@62" 105.34 1280 1336 1464 1704 960 960 962 997
    Modeline "1600x1024@62" 143.49 1600 1672 1848 2176 1024 1024 1026 1063

    EndSection

    edit2: is it possible to add multiple modelines? because if i go
    Modeline "1280x960@62" 105.34 1280 1336 1464 1704 960 960 962 997
    Modeline "1600x1024@62" 143.49 1600 1672 1848 2176 1024 1024 1026 1063

    it gives me only 1680x1050 and not both.

    edit3: solved that also by adding

    SubSection "Display"
    Depth 24
    Modes "1600x1024@62" "1280x960@62"
    EndSubSection

    now off to add various resolutions.... Finally my eyes are happy!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •