Results 1 to 7 of 7

Thread: SQL Ninja Help?

  1. #1
    Junior Member
    Join Date
    Sep 2008
    Posts
    26

    Default SQL Ninja Help?

    Hey all, when i try to sqlninja -m test
    configure the devices and everything right probably but it always give me an error saying could not create a socket to ip:80

  2. #2
    Member
    Join Date
    Sep 2008
    Posts
    306

    Default

    Quote Originally Posted by 325ci View Post
    Hey all, when i try to sqlninja -m test
    configure the devices and everything right probably but it always give me an error saying could not create a socket to ip:80
    Are you sure port 80 is open / not blocked on your test victim and did you try another port?
    Be sensitive in choosing where you ask your question. You are likely to be ignored, or written off as a loser, if you:

    * post your question to a forum where it's off topic
    * post a very elementary question to a forum where advanced technical questions are expected, or vice-versa
    * cross-post to too many different newsgroups
    * post a personal e-mail to somebody who is neither an acquaintance of yours nor personally responsible for solving your problem

  3. #3
    Junior Member
    Join Date
    Sep 2008
    Posts
    26

    Default

    well what other ports should i try i mean can i scan for any open port?

  4. #4
    Member
    Join Date
    Sep 2008
    Posts
    306

    Default

    Quote Originally Posted by 325ci View Post
    well what other ports should i try i mean can i scan for any open port?
    I've never tried it, but as the documentation tells, it is possible:
    port

    The port to connect to. If not specified, port 80 is assumed. For example:

    port = 443
    Just give it a try, and response the result.


    Update:
    I just tested for myself with port 22 (ssh) and port 80 (http) open. (local within backtrack)
    I used the command sqlninja -m test -d 2 and the output was something like (from my mind):

    Accept ... text ../ language.. / charset.. / content type..
    Connection closed
    Warning the server responded with http 404 not found
    Check config ...
    Injection not successful
    Not vunlerable or Error in config
    So it seems to run fine, but couldn't succeed coz i didn't set up my config yet (consciously)
    Be sensitive in choosing where you ask your question. You are likely to be ignored, or written off as a loser, if you:

    * post your question to a forum where it's off topic
    * post a very elementary question to a forum where advanced technical questions are expected, or vice-versa
    * cross-post to too many different newsgroups
    * post a personal e-mail to somebody who is neither an acquaintance of yours nor personally responsible for solving your problem

  5. #5
    Junior Member
    Join Date
    Sep 2008
    Posts
    26

    Default

    its saying trying to inject a waitfor delay than error: could not create socket to ip
    yes i tried the 443 port but same problem, is there any other doing the same job? or port scanner?

  6. #6
    Member
    Join Date
    Sep 2008
    Posts
    306

    Default

    Quote Originally Posted by 325ci View Post
    its saying trying to inject a waitfor delay than error: could not create socket to ip
    yes i tried the 443 port but same problem, is there any other doing the same job? or port scanner?
    Oh i thought you have a little knowledge about the things you do
    Search the forum for "nmap" , maybe "fast-track", and "db_autopwn".
    Be sensitive in choosing where you ask your question. You are likely to be ignored, or written off as a loser, if you:

    * post your question to a forum where it's off topic
    * post a very elementary question to a forum where advanced technical questions are expected, or vice-versa
    * cross-post to too many different newsgroups
    * post a personal e-mail to somebody who is neither an acquaintance of yours nor personally responsible for solving your problem

  7. #7
    Junior Member
    Join Date
    Sep 2008
    Posts
    26

    Default

    okay so i learned nmap and i can use, i see the open ports but i can't use sql ninja to get a session, i guess im doing the configuration wrong?
    http://sqlninja.sourceforge.net/sqlninjademo1.html
    this is what i'm following but it's just not giving me succesfull.

    is there any other way i can open a session ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •